Bug #45942 Insert delayed support
Submitted: 3 Jul 2009 15:53 Modified: 3 Jul 2009 16:53
Reporter: Bob Bobby Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:- OS:Any
Assigned to: Assigned Account CPU Architecture:Any

[3 Jul 2009 15:53] Bob Bobby
Description:
Why is there no "insert delayed" support on innodb Tables ?

Thanks

How to repeat:
Why is there no "insert delayed" support on innodb Tables ?

Thanks
[3 Jul 2009 16:53] Andrew Hutchings
Hello Bob,

Thanks for you bug report, here is a statement from bug #5777 which is a duplicate of this:

InnoDB is transactional engine so delayed insert does not make much sense for it.

It is not even possible to define the delayed behaviour in terms of transactions. The idea behind DELAYED is to return the control to the client program at once regardless of the result of the query.

Within transaction it doesn't make any sense as being atomic transaction can only finish with COMMIT or ROLLBACK.

It's theoretically impossible to have transaction which returns "unkonw" state to the client side.

Closing as duplicate of bug #5777