Bug #45697 ./mtr --force stops with "rpl_000015: slave-mi not supported anymore"
Submitted: 24 Jun 2009 10:17 Modified: 21 Jul 2009 11:13
Reporter: Sveta Smirnova Email Updates:
Status: Closed Impact on me:
None 
Category:Tools: MTR / mysql-test-run Severity:S7 (Test Cases)
Version:5.1 bzr OS:Any
Assigned to: Bjørn Munch CPU Architecture:Any
Tags: regression
Triage: Triaged: D1 (Critical)

[24 Jun 2009 10:17] Sveta Smirnova
Description:
MTR --force does not work anymore. This is critical as there is no possibility to run regression tests.

How to repeat:
$./mtr --force 
Logging: ./mtr  --force
MySQL Version 5.1.37
Checking supported features...
 - skipping ndbcluster, mysqld not compiled with ndbcluster
 - skipping SSL, mysqld not compiled with SSL
Collecting tests...
mysql-test-run: *** ERROR: rpl_000015: slave-mi not supported anymore
[14 Jul 2009 13:08] Bjørn Munch
You probably have a file suite/t/rpl/rpl_000015.slave-mi in your sandbox. Remove it.  I don't know what this is/was (and how you ended up having one) but it's someting deprecated and it leads to this error message.

BTW, this will not be related to the use of --force
[16 Jul 2009 8:25] Sveta Smirnova
Bjorn,

you are correct: this is not related to --force.

But after removing suite/rpl/t/rpl_000015.slave-mi I get:

$./mtr 
Logging: ./mtr  
090716 10:24:50 [Note] Plugin 'FEDERATED' is disabled.
090716 10:24:50 [Note] Plugin 'ndbcluster' is disabled.
090716 10:24:50 [Warning] Forcing shutdown of 2 plugins
MySQL Version 5.1.37
Checking supported features...
 - using ndbcluster when necessary, mysqld supports it
 - SSL connections supported
 - binaries are debug compiled
Collecting tests...
 - adding combinations for binlog
mysql-test-run: *** ERROR: rpl_rotate_logs: slave-mi not supported anymore
[16 Jul 2009 9:23] Sveta Smirnova
Re-checkout 5.1 tree, no slave-mi exists. So closed as "Not a Bug"
[21 Jul 2009 11:13] Bjørn Munch
Sorry, need to set this from Not a Bug to Closed to get it off my list