Bug #45633 InnoDB: Assertion failure in thread 60 in file row/row0mysql.c line 1534
Submitted: 20 Jun 2009 9:16 Modified: 20 Jun 2009 9:26
Reporter: River Tarnell Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.1.35 OS:Solaris (10 U7)
Assigned to:

[20 Jun 2009 9:16] River Tarnell
Description:
After importing a dump, then starting replication, MySQL crashed shortly afterwards with this error:

090620  9:02:29 [Note] Slave I/O thread: connected to master 'repl@127.0.0.1:3302',replication started in log 'db15-bin.006' at position 231881775
090620  9:06:43  InnoDB: Assertion failure in thread 60 in file row/row0mysql.c line 1534
InnoDB: Failing assertion: index->type & DICT_CLUSTERED

The server had the following unusual options set at the time:

innodb_doublewrite = 0
innodb_locks_unsafe_for_binlog = 1
innodb_flush_log_at_trx_commit = 0

The problem is repeatable; MySQL now crashed immediately whenever replication is started.

How to repeat:
Unknown
[20 Jun 2009 9:26] Valerii Kravchuk
This is a duplicate of Bug #45357.