Bug #45560 insert from trigger fires erroneous thread stack overrun error
Submitted: 17 Jun 2009 16:06 Modified: 19 Jun 2009 6:16
Reporter: bernd pichlbauer Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Errors Severity:S2 (Serious)
Version:5.1.33 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: insert, stack overrun, trigger

[17 Jun 2009 16:06] bernd pichlbauer
Description:
I have the same error as reported in bug #43472 however, using the version 5.1.33

The error msg:
Thread stack overrun:  6056 bytes used of a 131072 byte stack, and 128000 bytes needed.  Use 'mysqld -O thread_stack=#' to specify a bigger stack.

How to repeat:
you can find a copy of the database here:
http://files.getdropbox.com/u/962198/test.sql

insert a row into the table "insert_test" and you get the error
[17 Jun 2009 17:55] Valeriy Kravchuk
Thank you for the problem report. Please, try to repeat with a newer version, 5.1.35, and inform about the results.

I can't repeat neither with 5.0.84 nor with 5.1.36 built from recent bzr sources on Mac OS X.
[18 Jun 2009 16:00] bernd pichlbauer
That is difficult for me to test as I am using the XAMPP Mac OS X 1.0.1 version including MySql 5.1.33 and I don't know how to update the MySql version in Xampp.
[19 Jun 2009 6:16] Valeriy Kravchuk
Not repeatable with recent versions.
[23 Dec 2011 14:23] Gerd Katzenbeisser
Same error with Debian at version 5.1.49-3-log 

greets Gerd