Bug #45490 Right-clicking in the User Types window in the blank space creates an exception
Submitted: 15 Jun 2009 1:36 Modified: 1 Jul 2009 13:24
Reporter: Istvan Pusztai Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.1.13 OSS RC OS:Microsoft Windows (Windows 7 x64 RC Build 7100, XP x64)
Assigned to: Sergei Tkachenko CPU Architecture:Any
Tags: CHECKED, exception, right click, user types
Triage: Triaged: D2 (Serious) / R3 (Medium) / E3 (Medium)

[15 Jun 2009 1:36] Istvan Pusztai
Description:
Right-clicking in the User Types window in the blank space creates an exception.
Error details follow.

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at MySQL.GUI.Workbench.UserDatatypesForm.contextMenuStrip1_Opening(Object sender, CancelEventArgs e)
   at System.Windows.Forms.ToolStripDropDown.OnOpening(CancelEventArgs e)
   at System.Windows.Forms.ToolStripDropDown.SetVisibleCore(Boolean visible)
   at System.Windows.Forms.ContextMenuStrip.SetVisibleCore(Boolean visible)
   at System.Windows.Forms.ToolStripDropDown.Show(Control control, Point position)
   at System.Windows.Forms.ContextMenuStrip.ShowInternal(Control source, Point location, Boolean isKeyboardActivated)
   at System.Windows.Forms.Control.WmContextMenu(Message& m, Control sourceControl)
   at System.Windows.Forms.Control.WmContextMenu(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MySQLWorkbench
    Assembly Version: 5.1.13.5749
    Win32 Version: 5.1.13.5749
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLWorkbench.exe
----------------------------------------
wbprivate.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/wbprivate.wr.DLL
----------------------------------------
wbpublic.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/wbpublic.wr.DLL
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MySQLCsUtilities
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLCsUtilities.DLL
----------------------------------------
msvcm90
    Assembly Version: 9.0.30729.4918
    Win32 Version: 9.00.30729.4918
    CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4918_none_508da958bcbd2845/msvcm90.dll
----------------------------------------
MySQLGrtShell
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLGrtShell.EXE
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Assembly Version: 2.2.3449.32113
    Win32 Version: 2.2.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/WeifenLuo.WinFormsUI.Docking.DLL
----------------------------------------
WbPlugins
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/WbPlugins.DLL
----------------------------------------
Accessibility
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Aga.Controls
    Assembly Version: 1.6.0.0
    Win32 Version: 1.6.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/Aga.Controls.DLL
----------------------------------------
grt.db.fe
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/grt.db.fe.DLL
----------------------------------------
grt.helpers.be
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/grt.helpers.be.DLL
----------------------------------------
db.mysql.editors.wbp.fe
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/db.mysql.editors.wbp.fe.DLL
----------------------------------------
db.mysql.editors.wbp.wr
    Assembly Version: 0.0.0.0
    Win32 Version: 
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/db.mysql.editors.wbp.wr.DLL
----------------------------------------
sqlide.fe
    Assembly Version: 0.0.0.0
    Win32 Version: 0.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/sqlide.fe.DLL
----------------------------------------
ScintillaNet
    Assembly Version: 2.0.3449.32219
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/MySQL/MySQL%20Workbench%205.1%20OSS/ScintillaNet.DLL
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.4918 (NetFXspW7.050727-4900)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

How to repeat:
1. Open Workbench
2. Switch to the User Types window
3. Right-click in the white area (not over a row)
4. Exception occurs

Suggested fix:
Handle the right click and present a context menu that allows to add a new user data type (brings up the User Defined Types edit window). Even better would be to also allow editing (adding, renaming, etc. not just deleting) the user defined types within the User Types window.
[15 Jun 2009 1:41] Istvan Pusztai
Correction: the user type window does allow edition. I had to triple click for it to work (very odd behavior to say the least).
[15 Jun 2009 4:52] Valeriy Kravchuk
Thank you for the problem report.
[15 Jun 2009 10:19] Valeriy Kravchuk
Bug #45494 was marked as a duplicate of this one.
[30 Jun 2009 9:08] Sergei Tkachenko
Fix will be included in 5.1.15
[30 Jun 2009 19:03] Johannes Taxacher
fixed in version 5.1.16
[1 Jul 2009 13:24] Tony Bedford
An entry was added to the 5.1.16 changelog:

Right-clicking in a blank area of the User Types window generated an exception:

System.NullReferenceException: Object reference not set to an instance of an object.
   at MySQL.GUI.Workbench.UserDatatypesForm.contextMenuStrip1_Opening(Object sender,
CancelEventArgs e)
   at System.Windows.Forms.ToolStripDropDown.OnOpening(CancelEventArgs e)
...