Bug #45345 BUILD/compile-dist doesn't work on MacOSX 10.5.7
Submitted: 5 Jun 2009 9:55 Modified: 25 Nov 2009 8:06
Reporter: Georgi Kodinov Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.0 OS:Mac OS X (10.5.7, 10.6.2)
Assigned to: CPU Architecture:Any

[5 Jun 2009 9:55] Georgi Kodinov
Description:
Using xcode 3.1.2 on a fully updated leopard box I'm getting the following error out of BUILD/make-dist:
...
END OF BERKELEY DB CONFIGURATION
Including ndb shared memory transporter
configure: creating ./config.status
config.status: error: cannot find input file: extra/yassl/Makefile.in
gnumake: *** No targets specified and no makefile found.  Stop.
mbpro:~/mysql/work/B45286-5.0-bugteam$

How to repeat:
Try to make a source distribution on MacOSX

Suggested fix:
make sure BUILD/make-dist doesn't work only on linuxes
[5 Jun 2009 16:06] Valeriy Kravchuk
Thank you for the problem report. I was not able to repeat it with Mac OS X 10.5.6 and latest 5.0 from bzr:

valeriy-kravchuks-macbook-pro:mysql-5.0-work openxs$ echo $?
0
valeriy-kravchuks-macbook-pro:mysql-5.0-work openxs$ fc -l
...
535	 BUILD/compile-dist 
536	 echo $?
valeriy-kravchuks-macbook-pro:mysql-5.0-work openxs$ uname -a
Darwin valeriy-kravchuks-macbook-pro.local 9.6.0 Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386 i386

Did I miss anything (besides different minor Mac OS X version)?
[17 Jun 2009 9:24] Georgi Kodinov
Valeriy,

Still the same with the latest mysql-5.0 tree.
my autoconf is (from macports):
autoconf (GNU Autoconf) 2.63

my automake  (from macports):
automake (GNU automake) 1.10.2

Retesting with the built-in versions (autoconf (GNU Autoconf) 2.61 and automake (GNU automake) 1.10) yields : 
......
config.status: creating ndb/src/ndbapi/Makefile
config.status: creating ndb/src/mgmsrv/Makefile
config.status: creating ndb/src/mgmclient/Makefile
config.status: creating ndb/src/cw/Makefile
config.status: creating ndb/src/cw/cpcd/Makefile
config.status: creating ndb/test/Makefile
config.status: creating ndb/test/src/Makefile
config.status: creating ndb/test/ndbapi/Makefile
config.status: creating ndb/test/ndbapi/bank/Makefile
config.status: creating ndb/test/tools/Makefile
config.status: creating ndb/test/run-test/Makefile
config.status: creating mysql-test/ndb/Makefile
config.status: creating ndb/include/ndb_version.h
config.status: creating ndb/include/ndb_global.h
config.status: creating ndb/include/ndb_types.h
config.status: error: cannot find input file: Makefile.in
gnumake: *** No targets specified and no makefile found.  Stop.

You should try upgrading the xcode. This should do it. imho the os version is not that important
[3 Aug 2009 9:15] Susanne Ebrecht
What hardware are you using?

Intel or Power PC?
[17 Aug 2009 11:06] Georgi Kodinov
Intel Core 2 Duo box
[14 Sep 2009 7:13] Susanne Ebrecht
Do you still have this problem with actual bzr tree?

Are the other trees working? Is 5.1 or 5.4 making same trouble?
[29 Sep 2009 9:56] Georgi Kodinov
Suzanne,

I still have the same problem with the lated 5.0-bugteam. In 5.1-bugteam it appears to work.
[19 Nov 2009 7:43] Valeriy Kravchuk
Had you checked with Xcode 3.2.1?
[19 Nov 2009 8:15] Valeriy Kravchuk
Sorry, I meant Xcode 3.1.4 (3.2.x is for 10.6 and up...)
[19 Nov 2009 9:15] Georgi Kodinov
Still fails with Xcode 3.2 (I'm on snow leopard now). Updating to 3.2.1 and will retry.
[19 Nov 2009 12:06] Georgi Kodinov
Still the same with xcode 3.2.1 on MacOSX 10.6.2
[23 Nov 2009 17:16] Valeriy Kravchuk
With recent mysql-5.0 tree from bzr, Xcode 3.1.4, autoconf 2.61 and automake 1.10 I still can NOT repeat this problem on Mac OS X 10.5.6. Maybe only mysql-5.0-bugteam tree is affected?
[25 Nov 2009 8:06] Georgi Kodinov
It fails with me even on the 5.0 tree. I give up. probably it's something with my local setup.