Bug #45024 No Error Reporting during Synchronization
Submitted: 22 May 2009 8:01 Modified: 10 Jun 2009 10:37
Reporter: Christian Hass Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.1.12 OS:Mac OS X
Assigned to: Mike Lischke CPU Architecture:Any
Tags: CHECKED, Synchronize Error Reporting
Triage: Triaged: D3 (Medium) / R3 (Medium) / E2 (Low)

[22 May 2009 8:01] Christian Hass
Description:
Synchronization of the model with a database fails to report errors which leads to incomplete sync. The developer is not informed.

How to repeat:
Create a model which contains errors. e.g. create two tables with the same name

Suggested fix:
Error report, when sync was not successful.
[22 May 2009 17:39] Valeriy Kravchuk
Thank you for the problem report. Verified just as described. There are no error messages while syncing model with two tables having the same name.
[27 May 2009 20:32] Johannes Taxacher
Checking for duplicates in the model is the task of the validation module - which is only available in the Standard Edition.
If i create two tables, name them both `table1` and run that to a DB the database will accept both CREATE statements because they are syntactically correct. As WB uses "CREATE IF NOT EXISTS ..." syntax the first one will be created and the second one not ... while thats propably not the result the user expects (because he propably forgot to rename the second table properly) DB wont give an error on executing those statements which WB could show the user.
So imho thats not a bug, its just a feature thats only available in the Standard Edition of Workbench ... or did i miss the point?

br
tax
[27 May 2009 20:40] Christian Hass
The point is not the verification. The bug is that WB doesn't report errors during sync. As a user you don't get informed if sync was successful or not. Using 2 tables with the same name is just the shortest way to produce an error. But it applies to errors in general.
[9 Jun 2009 8:13] Mike Lischke
Synchronizing a change where a new table got the same name as an existing one indeed does not show an error, because there is no change at all sent to the server. Currently WB ignores that obviously. Validation is meant to catch this kind of problem. 

For any other type of error you can now view the error log, which was missing before.
[9 Jun 2009 11:49] Johannes Taxacher
errors (or success messages) are correctly viewed in the details-text-box which can be shown with the "show logs"-button.
will be included in 5.1.13
[10 Jun 2009 10:37] Tony Bedford
An entry was added to the 5.1.13 changelog:

Synchronization of the model with an external database failed to report errors. This meant there was the possibility of an incomplete synchronization, without the developer being informed.