Bug #45018 mysqld(-nt) crashes after faulty install - mysqld got exception 0xc0000005
Submitted: 21 May 2009 21:29 Modified: 21 May 2009 22:03
Reporter: outside world Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:5.0.88, 5.1.33, 5.1,34 OS:Microsoft Windows (XP RP3)
Assigned to:
Tags: crash, exception 0xc0000005, install, mysqld, mysqld-nt

[21 May 2009 21:29] outside world
Description:
I have a problem that starts during install. In all cases the problem was:
- during install: when running server config wizard, it gets not further then the first 2 items
- server runs, cannot change root password
- when server shut down and restarted it crashes immediately
- when windows starts, the server as a service crashes
- tried deleting logfiles, mysqld(-nt)says it can't write them because data files are corrupt

I tried:
- shutting down all firewalls (also during install), does not work

How to repeat:
On my machine:
- tried 5 days ago, mysql 5.1.34
- uninstalled, cleaned registry (mysql leaves a lot of rubbish)
- retried, same problem
- uninstalled, tried wamp (5.1.33) same problem
- uninstalled, tried today 5.0.88 same problem
- the error file suggests a bug, too big (don't know how to attach):

Suggested fix:
Another database? As a check I succesfully tried interbase and postgresql and both installed and run without any problem.
[21 May 2009 21:31] outside world
Error log containing a description of the problem

Attachment: lassus.err (application/octet-stream, text), 498.74 KiB.

[21 May 2009 22:03] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=44428 there are others bugs report with similar behavior.