Bug #4482 Connector J does noet return type String
Submitted: 9 Jul 2004 11:46 Modified: 29 Jul 2004 19:51
Reporter: M Wensink Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / J Severity:S1 (Critical)
Version:3.1.3-beta OS:Microsoft Windows (W2k)
Assigned to: Dean Ellis CPU Architecture:Any

[9 Jul 2004 11:46] M Wensink
Description:
The methode getObject() of class ResultSet does not return an object of type String but een array of Bytes. When I delete the part if (this.isBinaryEncoded) .. the problem is solved.

How to repeat:
Is obvious, I hope.

Suggested fix:
Revise the part for binary encoded data.

The snapshot of july hte 8th does not contain this part and returns the right type.
[29 Jul 2004 19:51] Mark Matthews
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html