Bug #44769 MySQL Enterprise Monitor emails not formatted properly
Submitted: 10 May 2009 22:16 Modified: 5 Jan 2011 17:44
Reporter: Roel Van de Paar (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Server Severity:S3 (Non-critical)
Version:2.0.5.7153 OS:Any
Assigned to: Darren Oldag CPU Architecture:Any

[10 May 2009 22:16] Roel Van de Paar
Description:
MySQL Enterprise Monitor are not formatted properly.

The example below is from a customer (Some text changed for privacy purposes)

Issues seen:
o Text in the subject and body is not formatted properly - it shows what looks like variables: '.name', '.advice', '.description' etc. instead of the actual values to be shown.
o No proper line formatting (CR/LF)
o No local time is being shown (GMT time only)

Subject: 
--------------
MySQL Enterprise Monitor Warning Alert: innodb_redo_logs_not_sized_correctly.name (SERVERNAME:3306)
--------------

Body
--------------
Server: SERVERNAME:3306 Time: 2009-01-01 01:01:01 GMT Advisor: Administration
- innodb_redo_logs_not_sized_correctly.name Problem Description
innodb_redo_logs_not_sized_correctly.description Advice
innodb_redo_logs_not_sized_correctly.advice Recommended Action
innodb_redo_logs_not_sized_correctly.command Links and Further Reading
innodb_redo_logs_not_sized_correctly.info Thresholds Warning : 0 Frequency
: 06:00:00 Expression (%have_innodb% == "YES") && ((%innodb_log_file_size%
* %innodb_log_files_in_group%) < LEAST(1073741824,
(%innodb_buffer_pool_size% / 2))) Evaluated Expression ("YES" == "YES") &&
((268435456 * 2) < LEAST(1073741824, (2147483648 / 2))) Transmitted by
MySQL Enterprise Monitor 2.0.5.7153 Copyright © 2005-2008 MySQL AB,
2008-2009 Sun Microsystems, Inc. All rights reserved. 
--------------

How to repeat:
Unsure. For this particular customer, issue in regards '.name' etc. is seen on one server, though formatting issues and GMT time only are universal.

Suggested fix:
Fix above mentioned issues.
[10 May 2009 22:17] Roel Van de Paar
s/MySQL Enterprise Monitor are not formatted properly./MySQL Enterprise Monitor emails are not formatted properly./
[15 May 2009 19:37] Gary Whizin
Waiting on reproducible test case or steps...
[8 Jun 2009 15:25] Sloan Childers
Events in 2.1 show times in GMT and local MEM server time in the emails.  The other formatting issues are due to the wrong AdvisorScript.jar bundle being installed.  An example would be downgrading a subscription from Platinum to Gold without unscheduling the rules that you are no longer licensed to use.
[15 Jun 2009 19:12] Sloan Childers
Any news on how to reproduce this problem?  Was it an advisor bundle / license mismatch or ???
[15 Jun 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[16 Jun 2009 0:40] Roel Van de Paar
Original issues reported and feedback:

o Text in the subject and body is not formatted properly - it shows what looks like variables: '.name', '.advice', '.description' etc. instead of the actual values to be shown.

After a re-import of the jar's, the emails are now showing correctly.

> The other formatting issues are due to the wrong AdvisorScript.jar bundle being installed.  An example would be downgrading a subscription from Platinum to Gold without unscheduling the rules that you are no longer licensed to use.

Feature request: how about updating MEM to send a warning e-mail explaining what is happening instead?

o No proper line formatting (CR/LF)

This issue was caused by Lotus Notes, when testing with another SMTP server and e-mail address, the mails looked fine.

o No local time is being shown (GMT time only)

> Events in 2.1 show times in GMT and local MEM server time in the emails.  

Great.
[14 Aug 2009 20:52] Enterprise Tools JIRA Robot
Sloan Childers writes: 
patch pushed to the 2.2 branch
[22 Sep 2009 15:28] Enterprise Tools JIRA Robot
Sloan Childers writes: 
Patch installed in versions => 2.2.0.1501.
[13 Oct 2009 15:10] Enterprise Tools JIRA Robot
Marcos Palacios writes: 
Verified fixed in service manager build 2.2.0.1501.

You can no longer import an advisor jar that is of a higher
subscription than you are licensed for.
[23 Oct 2009 16:45] Tony Bedford
An entry was added to the 2.2.0 changelog:

        MySQL Enterprise Monitor alert emails used incorrect formatting.

        The following problems occurred:

            Text in the subject and body was not formatted properly.
            Variables appeared to be displayed such as '.name',
            '.advice', and '.description', rather than values.

            Line formatting (CR/LF) appeared to be absent.

            No local time was shown (GMT time only).
[5 Jan 2011 17:44] John Russell
Changelog entry was added by Tony, don't think there is anything further from the followup bug actions.