Bug #44741 mysql_client_test [ fail ]
Submitted: 8 May 2009 8:43 Modified: 4 Jun 2009 19:43
Reporter: Hiroshi Kise Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Tests Severity:S3 (Non-critical)
Version:5.0.81, 5.0.82, 5.0, 5.1, 6.0 bzr OS:Linux (test failed)
Assigned to: CPU Architecture:Any
Tags: mysql_client_test [ fail ]
Triage: Needs Triage: D2 (Serious)

[8 May 2009 8:43] Hiroshi Kise
Description:
mysql-bug41486                 [ pass ]           mysql                          [ pass ]           mysql_client_test              [ fail ]

mysqltest: At line 12: command "$MYSQL_CLIENT_TEST --getopt-ll-test=25600M >> $MYSQLTEST_VARDIR/log/mysql_client_test.out.log 2>&1" failed

How to repeat:
configure --with-charset=utf8 --enable-assembler --with-mysqld-ldflags=-all-static --localstatedir=/data/mysql/data --without-readline --with-extra-charsets=all

make 

make test

-----------
gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)
[8 May 2009 9:06] Valeriy Kravchuk
Thank you for the problem report. Please, send the results of:

uname -a
getconf GNU_LIBC_VERSION

from your Linux.
[8 May 2009 9:36] Hiroshi Kise
[castor ~]#uname -a
Linux castor 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT 2007 i686 i686 i386 GNU/Linux

[castor ~]# getconf GNU_LIBC_VERSION
glibc 2.5
[8 May 2009 11:01] Sergei Golubchik
where did you get the sources from ?
[8 May 2009 14:32] Hiroshi Kise
>where did you get the sources from ?

Compressed GNU TAR archive (tar.gz):

http://dev.mysql.com/get/Downloads/MySQL-5.0/mysql-5.0.81.tar.gz/from/http://ftp.iij.ad.jp...
[11 May 2009 13:56] Miguel Solorzano
I couldn't repeat this issue with current source server in Ubuntu 9.04 64-bit:

mysql_client_test              [ pass ]          18426
[22 May 2009 9:48] Spunk Meyer
I have the exact same problem.

My configure line is different :
CFLAGS="-O3 -march=i686" CXX=gcc CXXFLAGS="-O3 -march=i686 -felide-constructors -fno-exceptions -fno-rtti" ./configure --prefix=/usr/local/mysql --with-extra-charsets=complex --enable-thread-safe-client --enable-local-infile --enable-assembler

mysql_client_test              [ fail ]

mysqltest: At line 12: command "$MYSQL_CLIENT_TEST --getopt-ll-test=25600M >> $MYSQLTEST_VARDIR/log/mysql_client_test.out.log 2>&1" failed

The result from queries just before the failure was:
exec of '/home/spunkmeyer/src/mysql-5.0.81/tests/mysql_client_test --no-defaults --testcase --user=root --port=9306 --socket=/home/spunkmeyer/src/mysql-5.0.81/mysql-test/var/tmp/master.sock --vardir=/home/spunkmeyer/src/mysql-5.0.81/mysql-test/var --getopt-ll-test=25600M >> /home/spunkmeyer/src/mysql-5.0.81/mysql-test/var/log/mysql_client_test.out.log 2>&1' failed, error: 256, status: 1, errno: 0

$ gcc --version
gcc (GCC) 4.2.4

$ getconf GNU_LIBC_VERSION
glibc 2.7
[22 May 2009 9:49] Spunk Meyer
I forgot :

$ uname -a
Linux emenem 2.6.27.7-smp #1 SMP Thu Nov 20 22:18:02 CST 2008 i686 AMD Duron(tm) Processor AuthenticAMD GNU/Linux
[28 May 2009 8:44] Spunk Meyer
I have tested today with version 5.0.82 and the problem persists :

mysqltest: At line 12: command "$MYSQL_CLIENT_TEST --getopt-ll-test=25600M >> $MYSQLTEST_VARDIR/log/mysql_client_test.out.log 2>&1" failed

The result from queries just before the failure was:
exec of '/home/spunkmeyer/src/mysql-5.0.82/tests/mysql_client_test --no-defaults --testcase --user=root --port=9306 --socket=/home/spunkmeyer/src/mysql-5.0.82/mysql-test/var/tmp/master.sock --vardir=/home/spunkmeyer/src/mysql-5.0.82/mysql-test/var --getopt-ll-test=25600M >> /home/spunkmeyer/src/mysql-5.0.82/mysql-test/var/log/mysql_client_test.out.log 2>&1' failed, error: 256, status: 1, errno: 0

Can someone update the bug description with version 5.0.82 ? Thank you.
[28 May 2009 9:10] Sveta Smirnova
Thank you for the feedback.

Could you please send content of file $MYSQLTEST_VARDIR/log/mysql_client_test.out.log  where $MYSQLTEST_VARDIR is PATH_TO_MYSQL_DIR/mysql-test/var?
[28 May 2009 9:49] Spunk Meyer
Here are the last lines of the file mysql_client_test.out.log :

#####################################
211 of (1/1): test_bug36326  
#####################################

	+------+
	| a    |
	+------+
	|    1 |	
	+------+

	1 row returned

	+------+
	| a    |
	+------+
	|    1 |	
	+------+

	1 row returned

 total parameters in stmt: `1` (expected: `1`)mysql_client_test.c:16387: check failed: 'sql_big_selects_5 == sql_big_selects_orig'

If you want the whole file i can add it but i didn't for now because it weights 300 kB.
[29 May 2009 10:02] Sveta Smirnova
Thank you for the feedback.

Please provide full log.
[29 May 2009 12:02] Spunk Meyer
the full mysql_client_test.out.log

Attachment: mysql_client_test.out.log (application/octet-stream, text), 307.12 KiB.

[2 Jun 2009 8:07] Sveta Smirnova
Thank you for the feedback.

Finally verified, although with another problem:

173 of (1/1): test_bug9735
...
mysql_client_test.c:785: check failed: 'field->length == expected_field_length'
[2 Jun 2009 8:09] Sveta Smirnova
To repeat one have to compile as described in the initial reply.

This looks like same problem like in bug #29705 and bug #27383
[2 Jun 2009 8:11] Sveta Smirnova
Sorry: mixed bugs in previous reply.

Bug #19829 and bug #43347
[2 Jun 2009 8:47] Sveta Smirnova
$getconf GNU_LIBPTHREAD_VERSION; 
NPTL 2.3.6
$ getconf GNU_LIBC_VERSION; 
glibc 2.3.6
[4 Jun 2009 19:43] Sveta Smirnova
Duplicate of early reported bug #43347