Bug #44730 mysqldump prints triggers and routines to stdout when using --tab
Submitted: 7 May 2009 21:15 Modified: 8 May 2009 5:05
Reporter: Aaron Bassett Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: mysqldump Command-line Client Severity:S3 (Non-critical)
Version:mysqldump Ver 10.11 Distrib 5.0.45, for OS:Linux
Assigned to:
Tags: mysqldump

[7 May 2009 21:15] Aaron Bassett
Description:
When using mysqldump to dump a table with a trigger on it using the --tab option to get a .sql file and a .txt file, the triggers are printed to stdout rather than to the .sql file.

How to repeat:
Create a table, and add a trigger to it.
Use mysqldump with the --tab option to create a .sql file with the schema for the table and a .txt file with the data for the table.

Expected result:
Trigger should be in the .sql file

Actual result:
trigger is printed to stdout

Suggested fix:
Make triggers get printed to the .sql file instead of stdout. I believe --routine suffers from the same problem, so you should probably fix that as well.
[8 May 2009 5:05] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #34861