Bug #44643 Non-standard path to Perl in scripts
Submitted: 4 May 2009 12:46 Modified: 10 Sep 2009 17:27
Reporter: Björn Wiberg Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.0.81 OS:IBM AIX (Community Edition, AIX 5.3 32-bit binary packaging)
Assigned to: Kent Boortz CPU Architecture:Any
Tags: regression

[4 May 2009 12:46] Björn Wiberg
Description:
The following files of mysql-5.0.81-aix5.3-powerpc.tar.gz require /usr/local/perl/bin/perl:

./bin/mysql_find_rows
./bin/mysql_fix_extensions
./bin/mysql_setpermission
./bin/mysql_zap
./bin/mysqlaccess
./sql-bench/bench-count-distinct
./sql-bench/bench-init.pl
./sql-bench/compare-results
./sql-bench/copy-db
./sql-bench/crash-me
./sql-bench/innotest1
./sql-bench/innotest1a
./sql-bench/innotest1b
./sql-bench/innotest2
./sql-bench/innotest2a
./sql-bench/innotest2b
./sql-bench/run-all-tests
./sql-bench/server-cfg
./sql-bench/test-ATIS
./sql-bench/test-alter-table
./sql-bench/test-big-tables
./sql-bench/test-connect
./sql-bench/test-create
./sql-bench/test-insert
./sql-bench/test-select
./sql-bench/test-transactions
./sql-bench/test-wisconsin

This differs from e.g. mysql-5.0.77-aix5.2-powerpc.tar.gz (notice the 5.2 architecture there!), which instead requires /usr/bin/perl. Which in turn appears to be more "standard" on AIX, as the perl.rte package creates a /usr/bin/perl symlink to the installed version:

bwiberg@melody-lp04:~$ lslpp -la | grep perl.rte
  perl.rte                  5.8.2.60  COMMITTED  Perl Version 5 Runtime

bwiberg@melody-lp04:~$ lslpp -f perl.rte | grep 'bin' | grep 'perl$'
                        /usr/opt/perl5/bin/find2perl
                        /usr/bin/find2perl -> /usr/opt/perl5/bin/find2perl
                        /usr/opt/perl5/bin/perl5.8.2 -> /usr/opt/perl5/bin/perl
                        /usr/opt/perl5/bin/perl

bwiberg@melody-lp04:~$ ls -l /bin/perl
lrwxrwxrwx  1 root system 28 2008-03-12 16:13 /bin/perl -> /usr/opt/perl5/bin/perl5.8.2

bwiberg@melody-lp04:~$ oslevel -s
5300-08-01-0819

How to repeat:
Just unpack mysql-5.0.81-aix5.3-powerpc.tar.gz and look at the first row of the mentioned files.

Suggested fix:
It would be great if this could be made consistent over the AIX line of binary releases, i.e., the AIX 5.3 packages should probably be changed so that they reference /usr/bin/perl instead of /usr/local/perl/bin/perl.
[4 May 2009 16:59] Sveta Smirnova
Thank you for the report.

Verified as described.
[8 May 2009 20:26] Daniel Fischer
Since we are not supporting AIX 5.2 anymore, the path will automatically be consistent across all AIX packages in the future. However, it should probably still be /usr/bin/perl.
[12 Jun 2009 9:10] Bugs System
Pushed into 5.1.36 (revid:joerg@mysql.com-20090611162132-wq3i5e6rqvcg0pgn) (version source revid:joerg@mysql.com-20090529134055-nnwgrfjdhr0ebmh8) (merge vers: 5.1.36) (pib:6)
[12 Jun 2009 9:11] Bugs System
Pushed into 5.0.84 (revid:joerg@mysql.com-20090611143247-ub720iread7cpftc) (version source revid:kent@kent-amd64-20090509214348-7rl4f4u9fortxfqv) (merge vers: 5.0.83) (pib:6)
[10 Jul 2009 11:21] Bugs System
Pushed into 5.4.4-alpha (revid:anozdrin@bk-internal.mysql.com-20090710111017-bnh2cau84ug1hvei) (version source revid:mhansson@mysql.com-20090616095106-lunvwomidjv62ww3) (merge vers: 5.4.4-alpha) (pib:11)
[26 Aug 2009 13:46] Bugs System
Pushed into 5.1.37-ndb-7.0.8 (revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)
[26 Aug 2009 13:46] Bugs System
Pushed into 5.1.37-ndb-6.3.27 (revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (version source revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (merge vers: 5.1.37-ndb-6.3.27) (pib:11)
[26 Aug 2009 13:48] Bugs System
Pushed into 5.1.37-ndb-6.2.19 (revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (version source revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (merge vers: 5.1.37-ndb-6.2.19) (pib:11)
[27 Aug 2009 16:33] Bugs System
Pushed into 5.1.35-ndb-7.1.0 (revid:magnus.blaudd@sun.com-20090827163030-6o3kk6r2oua159hr) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)
[6 Sep 2009 14:21] Kent Boortz
This problem was corrected in 5.0.84 and 5.1.36.

Could have been a problem for a few other platforms than AIX as
well where the Perl used during release build was not the default
"/usr/bin/perl".
[10 Sep 2009 17:27] Paul Dubois
Noted in 5.0.84, 5.1.36, 5.4.4 changelogs.

Some Perl scripts in AIX packages contained an incorrect path to the
perl executable.
[16 Jan 2010 1:07] Paul Dubois
Noted in 5.5.0 changelog.