Bug #44538 crash dump when running few select tests
Submitted: 29 Apr 2009 9:34 Modified: 4 May 2009 11:32
Reporter: Sunanda Menon Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.1.30 OS:Other (OpenSolaris X86 (snv_111a))
Assigned to:
Tags: joomla, OpenSolaris, x86

[29 Apr 2009 9:34] Sunanda Menon
Description:
When running following tests on OpenSolaris X86  on 32 bits version (and only this one) all the following tests are generating coredumps.

greedy_optimizer
insert_notembedded
join
join_crash
join_nested
join_outer
kill
order_by
subselect
type_blob

How to repeat:
mysql@grenache-26-vm11:~usr/mysql/mysql-test$ ./mysql-test-run --vardir=/var/tmp/mysql/mysql_32bit join
Logging: ./mysql-test-run --vardir=/var/tmp/mysql/mysql_32bit join
MySQL Version 5.1.30
Using dynamic switching of binlog format
Using ndbcluster when necessary, mysqld supports it
Setting mysqld to support SSL connections
Using MTR_BUILD_THREAD      = 0
Using MASTER_MYPORT         = 9306
Using MASTER_MYPORT1        = 9307
Using SLAVE_MYPORT          = 9308
Using SLAVE_MYPORT1         = 9309
Using SLAVE_MYPORT2         = 9310
Using NDBCLUSTER_PORT       = 9311
Using NDBCLUSTER_PORT_SLAVE = 9312
Using IM_PORT               = 9313
Using IM_MYSQLD1_PORT       = 9314
Using IM_MYSQLD2_PORT       = 9315
Killing Possible Leftover Processes
Removing Stale Files
Creating Directories
Installing Master Database
=======================================================

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

main.join                      [ fail ]

mysqltest: At line 114: query 'select t1.a from t1 as t1 left join t1 as t2 using (a) left join t1 as t3 using (a) left join t1 as t4 using (a) left join t1 as t5 using (a) left join t1 as t6 using (a) left join t1 as t7 using (a) left join t1 as t8 using (a) left join t1 as t9 using (a) left join t1 as t10 using (a) left join t1 as t11 using (a) left join t1 as t12 using (a) left join t1 as t13 using (a) left join t1 as t14 using (a) left join t1 as t15 using (a) left join t1 as t16 using (a) left join t1 as t17 using (a) left join t1 as t18 using (a) left join t1 as t19 using (a) left join t1 as t20 using (a) left join t1 as t21 using (a) left join t1 as t22 using (a) left join t1 as t23 using (a) left join t1 as t24 using (a) left join t1 as t25 using (a) left join t1 as t26 using (a) left join t1 as t27 using (a) left join t1 as t28 using (a) left join t1 as t29 using (a) left join t1 as t30 using (a) left join t1 as t31 using (a)' failed: 2013: Lost connection to MySQL server during query

The result from queries just before the failure was:
< snip >
INSERT INTO t2 VALUES (4,2,25,12,6500,11200);
INSERT INTO t2 VALUES (5,1,37,6,10000,12000);
select a.id, b.category as catid, b.state as stateid, b.county as countyid from t1 a, t2 b ignore index (primary) where (a.token ='a71250b7ed780f6ef3185bfffe027983') and (a.count = b.id);
id      catid   stateid countyid
27      2       12      11
28      2       12      11
29      2       12      25
26      1       6       37
select a.id, b.category as catid, b.state as stateid, b.county as
countyid from t1 a, t2 b where (a.token =
'a71250b7ed780f6ef3185bfffe027983') and (a.count = b.id) order by a.id;
id      catid   stateid countyid
26      1       6       37
27      2       12      11
28      2       12      11
29      2       12      25
drop table t1, t2;
create table t1 (a int primary key);
insert into t1 values(1),(2);
select t1.a from t1 as t1 left join t1 as t2 using (a) left join t1 as t3 using (a) left join t1 as t4 using (a) left join t1 as t5 using (a) left join t1 as t6 using (a) left join t1 as t7 using (a) left join t1 as t8 using (a) left join t1 as t9 using (a) left join t1 as t10 using (a) left join t1 as t11 using (a) left join t1 as t12 using (a) left join t1 as t13 using (a) left join t1 as t14 using (a) left join t1 as t15 using (a) left join t1 as t16 using (a) left join t1 as t17 using (a) left join t1 as t18 using (a) left join t1 as t19 using (a) left join t1 as t20 using (a) left join t1 as t21 using (a) left join t1 as t22 using (a) left join t1 as t23 using (a) left join t1 as t24 using (a) left join t1 as t25 using (a) left join t1 as t26 using (a) left join t1 as t27 using (a) left join t1 as t28 using (a) left join t1 as t29 using (a) left join t1 as t30 using (a) left join t1 as t31 using (a);

More results from queries before failure can be found in /var/tmp/mysql/mysql_32bit/log/join.log

Aborting: main.join failed in default mode.
To continue, re-run with '--force'.
Stopping All Servers
[29 Apr 2009 9:37] Valerii Kravchuk
Thank you for the problem report. Please, try to repeat with a newer version, 5.1.34, and inform about the results.
[1 May 2009 2:57] Sunanda Menon
Is this issue fixed in 5.1.34?
The problem is similar to http://bugs.mysql.com/bug.php?id=27147
[4 May 2009 11:32] Sveta Smirnova
This is duplicate of bug #41710