Bug #44416 MySQL 5.1 Crashes when trying to configure with Error 0
Submitted: 23 Apr 2009 3:06 Modified: 26 Jan 2010 12:53
Reporter: Elisa Lau Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S2 (Serious)
Version:5.1.34 OS:Microsoft Windows (XP SP2/3, W2K3)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D2 (Serious)

[23 Apr 2009 3:06] Elisa Lau
Description:
Unable to complete the MySQL Server Instance Configuration Wizard. 

I looked around, and typed 

mysqld -- console at the command prompt and it crashed again, below is the output:

090422 19:52:13  InnoDB: Page checksum 1575996416, prior-to-4.0.14-form checksum
 1371122432
InnoDB: stored checksum 0, prior-to-4.0.14-form stored checksum 0
InnoDB: Page lsn 0 0, low 4 bytes of lsn at page end 0
InnoDB: Page number (if stored to page already) 0,
InnoDB: space id (if created with >= MySQL-4.1.1 and stored already) 0
InnoDB: Page may be a freshly allocated page
090422 19:52:13InnoDB: Error: trying to access a stray pointer 82DB3FF8
InnoDB: buf pool start is at 02DA4000, end at 05CA4000
InnoDB: Probable reason is database corruption or memory
InnoDB: corruption. If this happens in an InnoDB database recovery, see
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: how to force recovery.
090422 19:52:13  InnoDB: Assertion failure in thread 1688 in file G:\mysql-5.1.3
4-winbuild\mysql-community-nt-5.1.34-build\storage\innobase\include\buf0buf.ic l
ine 264
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090422 19:52:13 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=26214400
read_buffer_size=65536
max_used_connections=0
max_threads=100
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 58231 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
006EAEC0    mysqld.exe!buf_frame_align()[buf0buf.ic:264]
006D08EC    mysqld.exe!page_dir_slot_get_rec()[page0page.ic:503]
0071B606    mysqld.exe!page_cur_search_with_match()[page0cur.c:311]
006D6BBC    mysqld.exe!btr_cur_search_to_nth_level()[btr0cur.c:520]
00700440    mysqld.exe!btr_pcur_open()[btr0pcur.ic:494]
00701116    mysqld.exe!btr_pcur_open_on_user_rec()[btr0pcur.c:550]
006F6B9A    mysqld.exe!dict_load_indexes()[dict0load.c:610]
006F6F07    mysqld.exe!dict_load_sys_table()[dict0load.c:1015]
00709028    mysqld.exe!dict_boot()[dict0boot.c:389]
006BF2AA    mysqld.exe!innobase_start_or_create_for_mysql()[srv0start.c:1521]
006AD773    mysqld.exe!innobase_init()[ha_innodb.cc:1755]
00442B88    mysqld.exe!ha_initialize_handlerton()[handler.cc:432]
00564C63    mysqld.exe!plugin_initialize()[sql_plugin.cc:1003]
005695A4    mysqld.exe!plugin_init()[sql_plugin.cc:1216]
004D086B    mysqld.exe!init_server_components()[mysqld.cc:3884]
004D0FA6    mysqld.exe!win_main()[mysqld.cc:4354]
004D13FD    mysqld.exe!mysql_service()[mysqld.cc:4530]
004D16A0    mysqld.exe!main()[mysqld.cc:4703]
0072AE6D    mysqld.exe!__tmainCRTStartup()[crt0.c:327]
003D2FD3
2D00646C
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
1. Install MySQL 5.1
2. Proceed with MySQL Server Instance Configuration Wizard (ver 1.0.15.0)
3. Check Standard Configuration, and proceed.
4. On the processing configuration screen, msyqld crashes on Start Service Error:
Could not start service MySQL, Error: 0
[23 Apr 2009 12:32] Miguel Solorzano
Thank you for the bug report. Which exactly server version are you tried to install 5.1.34?. Thanks in advance.
[23 Apr 2009 19:16] Elisa Lau
yes, it's 5.1.34
[27 Apr 2009 14:50] Arndt Lingscheid
Hi all,

I have tried the MySql versions from 4.1, 5.0 and 5.1 on Windows XP and W2K3. It always leads to the same error.

MySql Error 0.  ( When starting service ….. ) 

When trying to start the service manually the error 1067 occurs.

Regards Arndt
[27 May 2009 12:40] hercule dixhuit
Hi,

I try to install the 5.1.34 and I exactly have the same problem.

It's running on:
Virtual Box 2.2.2 (512Mo Dedicated ram, 5Go disk)
windows XP SP2

I tryed several solution proposed on the forum but none worked

please help

regards

Herc.
[31 May 2009 20:33] Zeppedy Maguire
Yep I get this too, nothing i've found fixes it so far

XP SP3
MySQL 5.1.34

Any help appreciated...
[18 Jun 2009 14:53] K Ru
The same odd crashes, version 5.1.35, OS WinXP SP3 32Bit 3GB ram

This is extract from my error log:
090618 17:17:34  InnoDB: Started; log sequence number 0 447562146
090618 17:17:34 [Note] Event Scheduler: Loaded 0 events
090618 17:17:34 [Note] mysqld: ready for connections.
Version: '5.1.35-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
090618 17:37:47  InnoDB: Assertion failure in thread 6924 in file .\row\row0mysql.c line 1534
InnoDB: Failing assertion: index->type & DICT_CLUSTERED
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090618 17:37:47 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=26214400
read_buffer_size=65536
max_used_connections=24
max_threads=100
threads_connected=23
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 58231 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x18f95408
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
InnoDB: Thread 7076 stopped in file .\handler\ha_innodb.cc line 5769
006B5906    mysqld.exe!row_unlock_for_mysql()[row0mysql.c:1534]
006BDB18    mysqld.exe!row_search_for_mysql()[row0sel.c:4090]
006AA670    mysqld.exe!ha_innobase::index_read()[ha_innodb.cc:4412]
0043AB39    mysqld.exe!handler::index_read_map()[handler.h:1390]
00447D56    mysqld.exe!handler::read_range_first()[handler.cc:4176]
00445E6C    mysqld.exe!handler::read_multi_range_first()[handler.cc:4050]
004D7A4B    mysqld.exe!QUICK_RANGE_SELECT::get_next()[opt_range.cc:8468]
004E9261    mysqld.exe!rr_quick()[records.cc:313]
0053C74D    mysqld.exe!mysql_delete()[sql_delete.cc:289]
00556878    mysqld.exe!mysql_execute_command()[sql_parse.cc:3273]
0055A8C3    mysqld.exe!mysql_parse()[sql_parse.cc:5933]
0055B3B3    mysqld.exe!dispatch_command()[sql_parse.cc:1218]
0055C1B7    mysqld.exe!do_command()[sql_parse.cc:861]
005DF511    mysqld.exe!handle_one_connection()[sql_connect.cc:1115]
0064588B    mysqld.exe!pthread_start()[my_winthread.c:85]
0072ADD3    mysqld.exe!_callthreadstart()[thread.c:293]
FCB0E900    
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 18F9F3B8=delete from contact_session where contact_id=29
thd->thread_id=10
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
InnoDB: Thread 2460 stopped in file .\os\os0sync.c line 574
InnoDB: Thread 7156 stopped in file .\os\os0sync.c line 271
InnoDB: Thread 6288 stopped in file .\sync\sync0arr.c line 337
[30 Jun 2009 17:49] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=45844 marked as duplicate of this one.
[21 Aug 2009 4:46] Susanne Ebrecht
Which config wizzard version did you use?
[21 Aug 2009 5:22] Roel Van de Paar
Version is mentioned in original report: 'MySQL Server Instance Configuration Wizard (ver 1.0.15.0)'
[24 Sep 2009 9:11] Susanne Ebrecht
Verified as described.

This bug is annoying.

Workaround is to disable innodb.
[21 Oct 2009 6:20] Susanne Ebrecht
Timothy,

it hits every Windows user.
The workaround here is not to download and use the MSI installer version.

Only MSI package is affected.
[21 Oct 2009 6:59] Susanne Ebrecht
It seems this need re-verifying with newest MySQL 5.1 version.
[24 Dec 2009 16:47] Valeriy Kravchuk
Please, check with a newer version, 5.1.41, and inform about the results.
[25 Jan 2010 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[26 Jan 2010 11:41] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=50122 it was marked as duplicate of this bug.
[26 Jan 2010 12:48] Abel Braaksma
Please see the report of the duplicate for a full workaround of this issue. This issue is still affecting every new version of MySQL / MSI installer. The cause of the problem is not reported in this thread, please see http://bugs.mysql.com/?id=50122&edit=2

Since the other thread has so much more information that leads to resolving this error and what causes it. I suggest we close this thread with a pointer and reopen the other thread. Duplicates are not always read in full and this can lead to critical information loss about this issue.
[26 Jan 2010 12:49] Abel Braaksma
Apologies, the link ought to be this: http://bugs.mysql.com/?id=50122
[26 Jan 2010 12:53] Miguel Solorzano
Right marking this as duplicate of http://bugs.mysql.com/bug.php?id=50122 I agree with user's last comment.