Bug #44408 Innodb_buffer_pool_size is set too big by default
Submitted: 22 Apr 2009 13:33 Modified: 23 Sep 2009 0:30
Reporter: Oli Sennhauser Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.4.0 OS:Any (Linux, Mac OS X)
Assigned to: CPU Architecture:Any

[22 Apr 2009 13:33] Oli Sennhauser
Description:
Starting MySQL with the default settings sets the innodb_buffer_pool_size to 1 Gbyte on my 1 Gbyte machine:

| innodb_buffer_pool_size | 1073741824 |

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
mysql    20512  0.6 10.8 1360868 111856 pts/4  Sl   15:24   0:03 mysqld

How to repeat:
client]

port          = 5400
socket        = /home/mysql/run/mysql-5400.sock

[mysqld]

port          = 5400
socket        = /home/mysql/run/mysql-5400.sock

log-error     = error.log

Suggested fix:
Official recommendation is: 80% of RAM.
[22 Apr 2009 17:32] Valeriy Kravchuk
Thank you for the bug report. Verified just as described.
[23 Apr 2009 13:31] Mikhail Izioumtchenko
this appears to be a 5.4 feature, not present in anything that Innobase released,
changing the category
[23 Apr 2009 13:33] Mikhail Izioumtchenko
correcting the status which I accidentally set to Feedback. Back to Verified
[27 Apr 2009 19:21] Omer Barnir
triage: setting to not a bug following discussion - 5.4 as a performance release is set out of the box to run on high end machines.
[28 Apr 2009 6:32] Sergei Golubchik
1GB is way too much. Just as the old default - 8M - was way too little.
The default configuration will run *slower* than 5.1 out of the box for many installations - as the vast majority of users that use the default settings don't use "high end machines" - and those that do, don't use default settings.
[25 Jun 2009 21:28] Allan Packer
A static default is a lot easier to implement, but it might be more useful to set it to either a percentage of system memory (70%, say) or 1GB, whichever is _lower_. That would allow a decent amount of memory on systems that could support it (up to 1GB), while still supporting systems with a smaller memory footprint.
[21 Sep 2009 20:40] Calvin Sun
Fixed in 5.4.3.
[23 Sep 2009 0:30] Paul Dubois
Noted in 5.4.3 changelog.

The default value of innodb_buffer_pool_size was set to 1GB in MySQL 
5.4.0. This was too large for many installations, so the default has
been lowered to 128MB.