Bug #44288 MySQL Administrator wont connect to localhost
Submitted: 15 Apr 2009 11:35 Modified: 15 Apr 2009 15:28
Reporter: Daniel Dinnie Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Administrator Severity:S2 (Serious)
Version:1.2.17 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: connect, server, to, wont

[15 Apr 2009 11:35] Daniel Dinnie
Description:
Hi

When I try connect MySQL Administrator to my MySQL Server, I get the following error message

"Either the service or the configuration file could not be found. Startup variables and service section are therefore disabled."

And once in the application, the "Service Control", "Startup Variables" and "Server Logs" sections are grayed out. If I go onto those sections, the application displays a message at the top, in red, "This section is only available when connected to localhost".

If I have a look at the "Server Information" tab, it says "MySQL Server is running". Also if I have a look at the "Catalogs" section, I can browser my databases and tables.

I assume (from the first error message above) that the application is looking for my configuration file, and cant find it. MySQL came installed with XAMPP, and is installed in "c:/program files/xampp/mysql", and the my.cnf file is in "c:/program files/xampp/mysql/bin/my.cnf". I tried looking for a place, in the application, where I could change the location of the configuration file, but couldn't find anything.

How to repeat:
Download and install xampp
Install to location "c:/program files/Xampp"

Download and install MySQL Administrator tools
Install to location "c:/program files/MySQL Tools"

Open MySQL ADministrator

Enter you MySQL user name and password (I have tried with the default user name: "root" and blank password, and my own user name and password)

Suggested fix:
There needs to be a place where you can edit the location of your configuration file.
[15 Apr 2009 15:28] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=42191.