Bug #44156 Default generated Foreign Key names can exceed the MySQL max indentifier length
Submitted: 8 Apr 2009 15:41 Modified: 27 Jul 2009 16:21
Reporter: Thorsten Kunz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.1.9 beta OS:Any (Ubuntu 8.10 x86_64)
Assigned to: CPU Architecture:Any
Tags: CHECKED
Triage: Triaged: D2 (Serious) / R3 (Medium) / E3 (Medium)

[8 Apr 2009 15:41] Thorsten Kunz
Description:
Auto generated FK names for two tables with long names will exceed the MySQL max identifier length.
It is also possible to manually enter longer names then MySQL supports.

Both cases should be fixed.

How to repeat:
Create two tables with long names then add an FK to one referencing the other. The generated FK name will exceed the max identifier length.

You can also manually add FK names that exceed the max identifier length.

Suggested fix:
a) add some logic to avoid auto generated FK names to exceed the identifier max length.

b) enforced a limit on the input field length to avoid manual entry of too long FK names
[8 Apr 2009 18:14] Valeriy Kravchuk
Thank you for the bug report.
[27 Jul 2009 16:21] Alfredo Kojima
This bug is a duplicate of bug #45139 which has been closed previously.