Bug #44073 'could not start service' message but service starts anyway!
Submitted: 3 Apr 2009 11:42 Modified: 15 Oct 2012 14:42
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:5.1.33, 6.0.10 OS:Microsoft Windows (Vista 32 bit)
Assigned to: Assigned Account CPU Architecture:Any
Tags: qc
Triage: Triaged: D3 (Medium)

[3 Apr 2009 11:42] Peter Laursen
Description:
The last times I have upgraded MySQL I had the error message 'could not start service' from Windows service manager when starting the service for the first time. Anyway the service *does* start.

How to repeat:
I install 'on top' of an older version (5.1.32 > 5.1.33, 6.0.9 > 6.0.10) using the MSI installer (the service was stopped when installer was invoked).  I skip the configuration wizard (in order to use the old my.ini). When I start service (using the MA tray applet) the error appears.

It also happens sometimes (but not very often) if I stop and restart the service after that

It is no big issue, only a little confusing!

Suggested fix:
no idea!
[6 Apr 2009 14:12] Miguel Solorzano
I couldn't repeat on Vista Home Premium 64-bit with 6.0.9->6.0.10 ( when installed 6.0.9 I got the reported bug couldn't start the service false message error).
[9 Apr 2009 10:30] Kenneth McLaren
Similar scenario for XP SP3 for a first time install.

The Configuration Wizard suspends showing a red cross against "Start Service" and displays the message "Could not start the service MySQL. Error: 0".

I followed the instructions above and found the data directory and inspected the error log to find that no errors have been reported and the service had in fact started.

I confirmed this from the Task Manager.
[17 Apr 2009 9:47] Peter Laursen
same when installe 5.1.34

Attachment: nostart.jpg (image/jpeg, text), 52.35 KiB.

[1 May 2009 15:11] Jon Cox
I have seen this same problem with 5.0.77 and 5.1.34 during install.  After it lists that server failed to start it will not apply the security settings.  It works with 5.0.67.  Steps to repeat with 5.2.34:

1) click on mysql-5.1.34-win32.msi
2) click next
3) select the custom radio button
4) highlight MySQL Server Datafiles
5) selct change and set to <root directory>\MySQL
6) click next
7) click install
8) click next through the adds
9) click finish
10) click next
11) click next
12) select the server machine radio button
13) click next
14) select the Transactional Database Only radio button
15) Set the path to the <root directory(choosen earlier)>\MySQL\data
16) click next
17) select the manual setting radio button
18) set the concurrent connetions to 25
19) click next
20) click next
21) select the Best Support For Multilingualism radio button
22) click next
23) check the Include Bin Directory in Windows PATH check box
24) eneter the desired password
25) check the Enable root access from remote machines checkbox.
26) click next
27) click execute
28) expect the start service task to fail
29) click cancel
[2 May 2009 19:54] Peter Laursen
also when upgrading 5.0.77 -> 5.0.81

Attachment: once more.jpg (image/jpeg, text), 18.44 KiB.

[12 May 2009 12:15] Peter Laursen
Same occured on Windows 7 (64 bit) when installing MySQL 5.1.34 (also 64 bit)
[21 May 2009 17:52] Peter Laursen
explanation follows!

Attachment: newversion.jpg (image/jpeg, text), 83.52 KiB.

[21 May 2009 17:55] Peter Laursen
This time I had a slightly different variation!  See image above.

Actually every thing went OK: 

SELECT USER, HOST FROM mysql.user

/*

user    host     
------  ---------
root    %        
root    localhost

*/

.. so annonymous user was deleted, remote root created (and root password was also created as I specified)!  But the config wizard *thinks* that it went wrong!  It did not!
[21 Jun 2009 19:48] Robert Safadi
Very poor product for Vista. I will remove it form my system and hope it will not corrupt my system. Very disappointing product called mysql.
[25 Jun 2009 20:20] Peter Laursen
for the 117th (129th?) time ..

Installing 5.4.1 64 bit on Win7 RC the same two old issues happened

1) 'could not start service' message occurred, but service *did start*
2) 'security settings' were not applied (root password not applied, anonymous user not deleted). Other config wizard options (like port, default engine and charset worked (what they always did btw.)).
[10 Jul 2009 12:17] Miguel Solorzano
Thank you for the bug report.
[10 Jul 2009 12:27] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=46111 was marked as duplicate of this one.
[2 Oct 2010 8:13] Peter Laursen
I have not experienced this for long time and did not see other reports recently.  Maybe it is now a "can't repeat" ?
[21 May 2012 14:55] Javier Rivera Zavala
Unable to reproduce. Everything worked as expected.
[15 Oct 2012 14:42] Erlend Dahl
Not repeatable on recent versions.