Bug #44064 Connector/Net 6.0.1 doesn't load in VS2008
Submitted: 3 Apr 2009 7:19 Modified: 8 Apr 2009 7:56
Reporter: Jimmy Lee Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.0.1 OS:Microsoft Windows
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: Connector/Net

[3 Apr 2009 7:19] Jimmy Lee
Description:
Connector/Net 6.0.1 causes error when trying to add Entity in VS2008. It complains about an error in the data provider.

How to repeat:
Add a new Entity Framework Model. VS2008 fails to even load the mysql connector driver. Sometimes causes the dialog box to crash.
[3 Apr 2009 13:38] Tonci Grgin
Hi Jimmy and thanks for your report.

I'd say primary problem is that VS2008 is not loading the c/NET driver so I'll change synopsis. As same happens on my box too, verified as described.

Win2K8SEx64, VS2005Pro and VS2008Pro, removed c/NET 5.2.5, installed c/NET 6.0.1.
Message: Package 'MySQL connector NET 6.0.1' has failed to load properly
[3 Apr 2009 13:40] Tonci Grgin
Same error in VS2005Pro.
[3 Apr 2009 13:49] Tonci Grgin
The following information was included with the event: 

.NET Framework Data Provider for MySQL: The data provider object factory service was not found.

the message resource is present but the message is not found in the string/message table
[3 Apr 2009 19:10] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/71346
[3 Apr 2009 19:13] Reggie Burnett
fixed in 6.0.2
[6 Apr 2009 9:03] Jimmy Lee
How do I undo the damage?

I've uninstalled 6.0.1 and reinstalled 6.0.0 and now the problem still persists?
[6 Apr 2009 9:39] Tony Bedford
An entry was added to the 6.0.2 changelog:

Connector/Net 6.0.1 did not load in Microsoft Visual Studio 2008 and Visual Studio 2005 Pro.

The following error message was generated:

.NET Framework Data Provider for MySQL: The data provider object factory service was not
found.
[6 Apr 2009 9:50] Tonci Grgin
Jimmy, I believe fixed version should be on mirrors soon if not later today.
[6 Apr 2009 12:22] Tonci Grgin
Bug#43436 was marked duplicate of this report.
[8 Apr 2009 7:09] Jimmy Lee
Hi guys it's still happening for me with 6.0.2.

It might not be 6.0.2, when I uninstalled 6.0.1 and installed 6.0.0 it was still a problem.

Tried uninstalling just the VS2008 plugin, and reinstalling that bit, and I'll have the error again.

Can someone help? VS seems to be ruined now... there must be a way to do a full uninstall?
[8 Apr 2009 7:56] Jimmy Lee
ok guys, sorry the drama. After even more uninstalling and reinstalling, things seems to be good.
[8 Apr 2009 7:59] Tonci Grgin
Jimmy, yes as I have just confirmed. Could you take a look into Bug#44141 and tell me, there, if you have similar problem? Are you running 32 or 64 bit version of Windows?