Bug #43945 Server Instance Configuration Wizard stuck at Processing configuration
Submitted: 29 Mar 2009 22:38 Modified: 30 Mar 2009 8:29
Reporter: David Hislop Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.1.32 OS:Microsoft Windows (XP SP3)
Assigned to:

[29 Mar 2009 22:38] David Hislop
Description:
MySQL Server Instance Configuration Wizard seems to stick at the Processing configuration step after clicking Execute.

It doesn't execute any of the four steps Prepare Configuration, etc.

I've tried this several times with 5.1 and 5.0 with the same result.

I've also tried custom settings and a vanilla install. The process MySQLInstanceConfig.exe is using 0% CPU and is Not Responding.

I have to kill off the process. When uninstalling, it sticks in the same place while trying to stop the (non-running) server process. Then I have to restart the PC.

I can't find any obvious log files that would help out with this issue.

Any help greatly appreciated.

regards - David

How to repeat:
Attempt to nstall MySQL Server 5.1 and configure.
[30 Mar 2009 4:13] Valerii Kravchuk
What exact version, 5.1.x, you had tried to install? Do you have any antivirus software on your XP?
[30 Mar 2009 4:53] David Hislop
Attempted to install 5.1.32 (mysql-5.1.32-win32.msi).

Antivirus software is ZoneAlarm 8.0.298.

I did try at least one installation with the antivirus software turned off, but I can't remember if it was after a clean restart. 

regards - David
[30 Mar 2009 6:09] Valerii Kravchuk
I had never used this software, but, please, try to turn it off (or allow mysqld.exe to start explicitely there somehow) and repeat installation. Also, try to install as Administrator. Inform about the results.
[30 Mar 2009 8:03] David Hislop
Before trying the reinstall with the antivirus off, I restarted the PC then just ran the Server Instance Configuration Wizard from the All Programs menu, answered the antivirus warnings that came up, and it worked.

Looks like there might be some weird interaction with Zonealarm and the Wizard during the installation that goes away after a restart.

In any case, it's working.

Thank you for your help.

regards - David
[30 Mar 2009 8:29] Valerii Kravchuk
OK, so I'd say it is more a problem of interaction with Zonealarm than a bug in MySQL's code.
[21 Apr 2012 12:59] Anurag Arnab
I have the same bug on Windows 7 Ultimate 64 bit and I don't even have an anti-virus
[16 Jul 2012 8:04] JASE IT Staff
Same here with Windows Server 2008 R2. Please assist. No antivirus is running.
[17 Jul 2012 12:45] mrt know
best answer is here :

 http://boardreader.com/thread/MySQL_Server_Instance_Configuration_Wiza_693hgX7xle.html