Bug #43934 my.ini templates do not start the server
Submitted: 28 Mar 2009 20:16 Modified: 29 Mar 2009 19:51
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:6.0.10 OS:Microsoft Windows (vista 32 - likely any)
Assigned to:
Tags: qc

[28 Mar 2009 20:16] Peter Laursen
Description:
It seems that the .ini templates shipped with server 6.0.10 are not valid for this server version.

The server will not start with those.  I tested my-small.ini and my-medium.ini. Windows service manager returns "could not start service". (however I upgraded from 6.09 and the existing my.ini from before the upgrade worked.  This one was probably generated by configuration wizard shipped with some very early 6.0.x version)

How to repeat:
Rename one of the template files to my.ini and try to restart the server. Service fails to start.

Suggested fix:
Test with files before releasing new versions.
[29 Mar 2009 8:38] Peter Laursen
another report was here:
http://bugs.mysql.com/bug.php?id=43931

I really looks like those template files are not systematically tested and updated!
[29 Mar 2009 12:54] Peter Laursen
btw: is it interesting to have this in the file(s):

[isamchk]
key_buffer = 8M
sort_buffer_size = 8M

(but it is not because of this that server does not start).
[29 Mar 2009 19:26] Peter Laursen
As I understand those templates have completely outdated ISAM settings.  I would have expected some relevant Falcon and Maria settings (if not Maria uses the MyISAM settings).
[29 Mar 2009 19:37] Valerii Kravchuk
I think this is a duplicate of bug #34521.
[29 Mar 2009 19:51] Peter Laursen
Please see my comment in http://bugs.mysql.com/bug.php?id=34521