Bug #43679 Attempted to read or write protected memory
Submitted: 16 Mar 2009 15:26 Modified: 18 Mar 2009 11:32
Reporter: Cahya Subiyakto Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.30 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: crash, data lost, Memory, protected

[16 Mar 2009 15:26] Cahya Subiyakto
Description:
Problem Step-by-Step:

1. all of sudden I get this error:
"Unknown Exception caught in c:\document and settings\mysqldev\my documents\visual studio 2005\projects\workbench\backend\windows\wb.wr\src\Wb.h at line 1010"
All I can do is just press "OK" Button.

2. next error message:
"Unknown Exception caught in c:\document and settings\mysqldev\my documents\visual studio 2005\projects\workbench\backend\windows\wb.wr\src\Canvas.h at line 146"
All I can do is also just press "OK" Button.

3. next error message:
"Attempted to read or write protected memory. This is often an indication that other memory is corrupt."

4. next error message:
"Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

Attempted to read or write protected memory. This is often an indication that other memory is corrupt."

Detailed system message will be posted in txt file.

From this point on, if i tried to continue, WB somehow worked, but not correctly. In certain point of time it will crash again with the same error.
I tried to continue in hope that i could at least save my work. Unfortunately, i couldn't save it either, because I always got the same error.

How to repeat:
On my System, i just have to start MySQL Workbench, load my file.
Then work normally and wait WB to crash.
[18 Mar 2009 11:14] Susanne Ebrecht
Many thanks for writing a bug report.

The problem is related to your installed Visual Studio. Seems that Workbench and Visual Studio will bite each other.

This is a duplicate of bug #43331
[18 Mar 2009 11:32] Cahya Subiyakto
I found a work around.

The problem is only apply if I opened the file from Windows Explorer (double click on the file name directly).

If I open WB first, then open the file from WB, then I don't get any error, and it works properly.

Anyway, for me it is a bug.
Thanks.