Bug #4360 Connector/J DatabaseMetadata getTypeInfo
Submitted: 1 Jul 2004 9:21 Modified: 1 Jul 2004 15:37
Reporter: Wray Johnson Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Connector / J Severity:S2 (Serious)
Version:MySQL-AB JDBC Driver 3.0 OS:Microsoft Windows (Windows XP)
Assigned to: Mark Matthews CPU Architecture:Any

[1 Jul 2004 9:21] Wray Johnson
Description:
The DatabaseMetadata.getTypeInfo method does not return the datatype 1111/'int unsigned' which can be/is returned by the DatabaseMetadata .getColumns method as a column type.

Also, DatabaseMetadata.getTypeInfo returns type names in upper case while DatabaseMetadata .getColumns returns type names in lower case.

How to repeat:
Create database from: http://home.zonnet.nl/rhjlie/download/mysql/createmobilefishdb.sql

Get DatabaseMetadata.getTypeInfo
Get getColumns for 'mobilefishdb.address.userid'

Suggested fix:
Make the 1111/'int unsigned' data type be returned by the DatabaseMetadata.getTypeInfo method.

Make DatabaseMetadata .getColumns returns type names in upper case.
[1 Jul 2004 15:37] Mark Matthews
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional info:

The case mismatch of types is not a bug, you can force all type names from getColumns() to be uppercase by adding the 'capitalizeTypeNames' to your JDBC connection URL or properties, and setting it to 'true'.

I will open a feature request for the second part of your issue, which is for getTypes() to return 'unsigned' types as well.