Bug #43548 Install and default log file size
Submitted: 10 Mar 2009 23:13 Modified: 11 Mar 2009 7:58
Reporter: Andrew 007 Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.1.32 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: install, log, service

[10 Mar 2009 23:13] Andrew 007
Description:
Hello,
after installing MySQL 5.1.32 on WIN2003, the "MySQL Server Instance Config Wizard" is not able to configure the Windows service because of the following error:

InnoDB: Error: log file .\ib_logfile0 is of different size 0 40894464 bytes
InnoDB: than specified in the .cnf file 0 10485760 bytes!
[ERROR] Plugin 'InnoDB' init function returned error.
[ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
[ERROR] Unknown/unsupported table type: INNODB
[ERROR] Aborting

The problem seems to be the default my.ini created by the "MySQL Server Instance Config Wizard".

How to repeat:
Install MySQL 5.1.32 on WIN 2003 and run:
bin\mysqld --defaults-file="C:/Program Files/MySQL/MySQL Server 5.1/my.ini" --standalone --console

Suggested fix:
Verify the default my.ini file create by the "MySQL Server Instance Config Wizard" in the msi of the version 5.1.32.
[11 Mar 2009 7:35] Sveta Smirnova
Thank you for the report.

Did you actually update previous installation? I.e. did you have InnoDB files before installing version 5.1.32?
[11 Mar 2009 7:46] Andrew 007
No, I did a fresh installation
[11 Mar 2009 7:58] Sveta Smirnova
Thank you for the feedback.

This is really duplicate of bug #42820. Please read comments there to find workaround to solve this problem temporarily until bug #42820 is fixed.
[4 Oct 2012 7:27] Marko Mäkelä
The log file size problem is a duplicate of Bug#13494.