Bug #43374 Problem starting mysql service after installing mysql 5.1.31
Submitted: 4 Mar 2009 15:11 Modified: 5 May 2009 5:22
Reporter: sandeep chitturi Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Installing Severity:S3 (Non-critical)
Version:mysql 5.1.31-win32 OS:Microsoft Windows (vista home premium)
Assigned to:
Tags: i am not able to start my sql service after installing with mysql-essential-5.1.
Triage: Triaged: D2 (Serious)

[4 Mar 2009 15:11] sandeep chitturi
Description:
i am a new to mysql,i am trying to install mysql 5.1.31 on vista home premium,before installing i disabled UAC and and my anti virus,but after installing with mysql-essential-5.1.31-win32.msi and running configure i am not able to start the mysql service,i do not know if it is bug or not but i tried every thing on net.can any one please help with it.if not a bug can you please tell me were can i post my question to get the solution.please help i have one whole day with this problem.

How to repeat:
just after installing
[4 Mar 2009 15:12] sandeep chitturi
my .ERR file

Attachment: WorkHorse.err (application/octet-stream, text), 13.12 KiB.

[4 Mar 2009 15:34] Miguel Solorzano
Thank you for the bug report. In you err file you have:

InnoDB: Error: log file .\ib_logfile0 is of different size 0 25165824 bytes

then look your my.ini file for datadir option variable. Go to that directory
and see if the InnoDB files were created there. Print here the output of the dir command in the data directory. Thanks in advance.
[4 Mar 2009 16:20] sandeep chitturi
output is:

C:\Program Files\MySQL\MySQL Server 5.1\data>dir
 Volume in drive C has no label.
 Volume Serial Number is 0CCA-1370

 Directory of C:\Program Files\MySQL\MySQL Server 5.1\data

03/04/2009  02:03 AM    <DIR>          .
03/04/2009  02:03 AM    <DIR>          ..
03/04/2009  02:03 AM        10,485,760 ibdata1
               1 File(s)     10,485,760 bytes
               2 Dir(s)  71,486,431,232 bytes free
[4 Mar 2009 16:21] sandeep chitturi
and thanks for replaying
[4 Mar 2009 16:36] Miguel Solorzano
Thank you for the feedback. Please search for a file called ib_logfile0 maybe at:

C:/Documents and Settings/All Users/Application Data/MySQL/MySQL Server 5.1/Data/

if you find files called ib_logfileX and if you don't have data to preserve (your install is a fresh one not an upgrade) then delete these files and try to start the service. If you have problems attach your my.ini file here. Thanks.
[4 Mar 2009 17:15] sandeep chitturi
my.ini file

Attachment: my.ini (application/octet-stream, text), 8.71 KiB.

[4 Mar 2009 17:16] sandeep chitturi
my .err file new one

Attachment: WorkHorse.err (application/octet-stream, text), 1.08 KiB.

[4 Mar 2009 17:18] sandeep chitturi
i did what you have said i got the same error and i find my error file at C:\ProgramData\MySQL, but not the location that you said,is that a problem.

thanks in advance
[4 Mar 2009 17:20] sandeep chitturi
you can find my files as attachments in above posts
[4 Mar 2009 17:25] sandeep chitturi
sorry i found .err file at C:\ProgramData\MySQL\MySQL Server 5.1\data
[4 Mar 2009 17:31] Miguel Solorzano
Looking your err file I assume the server is running after created the InnoDB files:

InnoDB: Foreign key constraint system tables created
090304 12:13:07  InnoDB: Started; log sequence number 0 0
090304 12:13:12 [Note] Event Scheduler: Loaded 0 events
090304 12:13:12 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.31-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
[4 Mar 2009 17:48] sandeep chitturi
so can you tell me the solution to this problem.as i am new,can you please be more detail about the solution.
[4 Mar 2009 18:08] Miguel Solorzano
Thank you for feedback. There are several bugs reported related to this one and I just tried to help you to get the service running. So it is a bug which need to be fixed. Thanks.
[30 Mar 2009 18:50] Miguel Solorzano
Bug http://bugs.mysql.com/bug.php?id=43248 has been marked as duplicate of this one.
[3 Apr 2009 17:14] Michael Manning
I appear to be having the same problem. Windows Vista Home Premium SP1, tried installing MySQL 5.1.31, and couldn't ever get the service to start. Removed the service, reinstalled several times, no luck. Today I downloaded and tried again with MySQL 5.1.33, and again no luck with several attempts. The MySQL service appears in my service list, but isn't running, and can't be started (hard fails when I try to start it via services manager).

The one difference from this ticket with my scenario that I see is that at no point have I found a .err file written out into any directory. Should we assume my issue is a dupe of this ticket, or should I file a new one?
[3 Apr 2009 17:19] Tonci Grgin
Michael, I think you can safely assume it's same problem.
[23 Apr 2009 20:39] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=44446 marked as duplicate of this one.
[23 Apr 2009 21:37] bryan costanich
when is this going to be fixed? this is a blocking issue if you're automating the install.
[24 Apr 2009 12:12] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=44452 has been marked as duplicate of this one.
[5 May 2009 5:22] Susanne Ebrecht
This is a duplicate of bug #42820
[10 Aug 2009 14:17] Hot Zert
I have some problem, In Windows XP's Application Event, there always are four entries all pointed to InnoDB can not be start.
[10 Aug 2009 14:19] Hot Zert
BTW, my windows is XP Home + SP3 and MySQL is mysql-5.1.37-win32.msi.
If no Transaction Support, mysql can be installed normally.