Bug #43235 Extra slashes inserted with UDFs when forward engineering SQL script
Submitted: 26 Feb 2009 16:09 Modified: 19 Oct 2009 12:30
Reporter: Stephen Barton Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.30 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: TTREV

[26 Feb 2009 16:09] Stephen Barton
Description:
I have added a user defined function to my project by adding it using "Add Routine". DDL Syntax is OK, but when I forward engineer to an SQL script, two extra '/' are inserted in the script just before the "CREATE FUNCTION" statement, like this:

DELIMITER //
//
CREATE FUNCTION add_vehicle_history()
  RETURNS INT
BEGIN

This does NOT happen with procedures added as a routine.

How to repeat:
Create a UDF and paste into a new routine. Forward engineer to create an SQL script and the extra slashes should be visible in the SQL script.
[26 Feb 2009 16:15] Stephen Barton
Correction: With a procedure, it seems 'DELIMITER' is missing:

//

CREATE PROCEDURE add_system_note
[26 Feb 2009 16:35] MySQL Verification Team
Thank you for the bug report.
[19 Oct 2009 12:30] Susanne Ebrecht
This is a duplicate of bug #39929