Bug #43155 System.AccessViolationException
Submitted: 24 Feb 2009 16:45 Modified: 18 Aug 2010 0:01
Reporter: David Lewis Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.0.30, 5.2.26pre3 OS:Microsoft Windows
Assigned to: Mike Lischke CPU Architecture:Any
Tags: access, AccessViolationException, CHECKED, exception, Memory, protected, system, violation
Triage: Needs Triage: D1 (Critical) / R3 (Medium) / E3 (Medium)

[24 Feb 2009 16:45] David Lewis
Description:
An error message popped up (see attached file), whilst I was viewing an E-R diagram.

After I had copied the error details, I then clicked on continue, hoever the error message reappeared (don't know if it was the same error message (sorry), and after clicking on Continue again, the error message appeared yet again.
This went on for 3-4 times, until Windows reported that the application had crashed and forced me to quit the application, and therefore loosing all changes I had made (luckily I had saved the document 10 minutes previously).

How to repeat:
I have been unable to reporocude this error, and I am unsure what cause this as the error just popped up (though, if it helps, I did create a foreign key from one entity to another 60 seconds before the error).
[24 Feb 2009 16:46] David Lewis
The error messge that was thrown

Attachment: error_message.txt (text/plain), 7.55 KiB.

[25 Feb 2009 0:19] Miguel Solorzano
Thank you for the bug report. Unlucky I couldn't repeat too, could you please provide the output of Help->System Info for the record?. Thanks in advance.
[25 Feb 2009 9:18] David Lewis
Here is the information given by Help -> System Information:

Looking for user plugins in C:\Documents and Settings\david\Application Data\MySQL\Workbench\plugins
MySQL Workbench OSS for Windows version 5.0.30
Cairo Version: 1.5.12
Rendering Mode: GDI Rendering
OpenGL Driver Version: Not Detected
OS: Windows XP
CPU: 2x Intel(R) Pentium(R) 4 CPU 2.80GHz, 2.0 GB RAM
Video adapter info:
Adapter type: ATI Radeon X300/X550/X1050 Series
Chip Type: ATI Radeon Graphics Processor (0x5B60)
BIOS String: 113-A33406-100
Video Memory: 131072 KB

Also, if it helps, I had updated the version from 5.0.27 to 5.0.30 earlier that day, and this was the first time I had edited my project with the new version. Unfortunately I have still not been able to reproduce the bug, even with a copy of my old project.
[1 Mar 2009 14:45] Gene Sawyer
Dump after exception

Attachment: AccessViolation.txt (text/plain), 5.36 KiB.

[1 Mar 2009 14:46] Gene Sawyer
5.0.24 Workbench file which crashes 5.0.30 ER modeler

Attachment: GenericBidEngineDB.mwb (application/octet-stream, text), 38.31 KiB.

[2 Mar 2009 11:34] Valeriy Kravchuk
I was able to repeat this problem by opening your .mwb uploaded and adding a foreign key from CustomerAnalytics to Remittance table.
[5 Jun 2009 9:10] Mike Lischke
I cannot reproduce this problem, not even with the provided model file. However, there has been quite a large overhaul of the internal handling in the canvas in version 5.1, so it is much less likely to see such a problem again (if at all). Since we want to replace 5.0 by 5.1 we rather focus on 5.1 and fix any problems there. So, please try your model etc. in 5.1 (either the beta or the RC which is due soon) and let us know if that works for you then. Thank you.
[5 Jul 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[22 Jul 2010 4:45] Roel Van de Paar
Incorrect bug status, should have gone back to verified so that it can be re-checked (without time limitation). Valeriy, can you check you can't reproduce the same anymore?
[22 Jul 2010 4:47] Roel Van de Paar
I cannot reproduce the issue on 5.2.25. Valeriy, do you remember what you did before to crash it?
[11 Aug 2010 4:58] Roel Van de Paar
Had this issue on 5.1.26pre3 on Win7 x64 HP.

Attachment: trace.txt (text/plain), 2.85 KiB.

[11 Aug 2010 5:01] Roel Van de Paar
s/5.1.26pre3/5.2.26pre3/
[11 Aug 2010 5:03] Roel Van de Paar
Backtrace

Attachment: backtrace.txt (text/plain), 29.78 KiB.

[11 Aug 2010 5:07] Roel Van de Paar
From a Windows backtrace perspective, this crash is identical to the one in bug #55719:

------
EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 0000000000000000
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 0
EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid
ADDITIONAL_DEBUG_TEXT:  Followup set based on attribute [Is_ChosenCrashFollowupThread] from Frame:[0] on thread:[PSEUDO_THREAD]
LAST_CONTROL_TRANSFER:  from 0000000063c58c68 to 00000000764d438d
DEFAULT_BUCKET_ID:  STACKIMMUNE
PRIMARY_PROBLEM_CLASS:  STACKIMMUNE
BUGCHECK_STR:  APPLICATION_FAULT_STACKIMMUNE_NOSOS_ZEROED_STACK
STACK_TEXT:  00000000`00000000 00000000`00000000 mysqlworkbench.exe+0x0
FAILURE_BUCKET_ID:  STACKIMMUNE_80000003_MySQLWorkbench.exe!Unknown
BUCKET_ID:  X64_APPLICATION_FAULT_STACKIMMUNE_NOSOS_ZEROED_STACK_mysqlworkbench.exe
------

The above all match.

Though the actual in-Workbench-stack-trace is different.
[11 Aug 2010 5:34] Roel Van de Paar
See bug #55904: the Windows backtrace is identical, the in-Workbench-trace is different.
[11 Aug 2010 8:09] Mike Lischke
Closing this report again as it seems to be kinda duplicate of Bug #55904.