Bug #43024 Maria library Compile fails with latest pull on Windows 32-bit VS2003
Submitted: 19 Feb 2009 15:17 Modified: 24 Feb 2009 18:45
Reporter: Miguel Solorzano Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Maria storage engine Severity:S3 (Non-critical)
Version:6.0 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: compiling
Triage: Needs Triage: D4 (Minor)

[19 Feb 2009 15:17] Miguel Solorzano
Description:
The below error happens when compiling Maria engine on Windows 32-bit with pull revno 3061:

c:\dbs\mysql-6.0\storage\maria\ma_non_trans_log.c(251): error C2143: syntax error : missing ';' before 'type'
c:\dbs\mysql-6.0\storage\maria\ma_non_trans_log.c(251): error C2065: '_db_stack_frame_' : undeclared identifier
c:\dbs\mysql-6.0\storage\maria\ma_non_trans_log.c(251): warning C4133: 'function' : incompatible types - from 'int *' to '_db_stack_frame_ *'
c:\dbs\mysql-6.0\storage\maria\ma_non_trans_log.c(343): warning C4133: 'function' : incompatible types - from 'int *' to '_db_stack_frame_ *'

How to repeat:
see description

Suggested fix:
-
[24 Feb 2009 18:45] Sergei Golubchik
duplicate of bug#43131