Bug #43018 Unnessary --skip-federated option in .cnf file.
Submitted: 19 Feb 2009 12:54 Modified: 5 Mar 2009 18:24
Reporter: Kamil Zbikowski Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1.31 OS:Linux
Assigned to: Paul Dubois CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[19 Feb 2009 12:54] Kamil Zbikowski
Description:
It happened while I i tried to execute following the manual:
/mysql_install_db.sh --user=mysql --basedir=/usr/local/mysql --defaults-file=/etc/my.cnf 

It returned:

Installing MySQL system tables...
090219 13:00:52 [ERROR] /usr/local/mysql/libexec/mysqld: unknown option '--skip-federated'
090219 13:00:52 [ERROR] Aborting

090219 13:00:52 [Note] /usr/local/mysql/libexec/mysqld: Shutdown complete

Another thing was that i had to use this mysal_install_db 

             http://lists.mysql.com/commits/62477

How to repeat:
Execute 

/mysql_install_db.sh --user=mysql --basedir=/usr/local/mysql --defaults-file=/etc/my.cnf 

and the my.cnf is (following the manual) copied from the support-files/my-medium.cnf.

Suggested fix:
I'm not sure about it but it seems illogical to me that I haven't compiled source with option '--with-federated-storage-engine' and after that I should skip it. 

I've commented this line and everything went fine but from my point of view this shouldn't happened in an GA release. So maybe it should be checked if federated-storage-engine was compiled in.
 
Please correct me if I'm wrong.
[20 Feb 2009 7:11] Sveta Smirnova
Thank you for the report.

According to http://dev.mysql.com/doc/refman/5.1/en/option-files.html "MySQL provides a number of preconfigured option files that can be used as a basis for tuning the MySQL server. Look for files such as my-small.cnf, my-medium.cnf, my-large.cnf, and my-huge.cnf, which are sample option files for small, medium, large, and very large systems." So my-medium.cnf is just template for the configuration file and one should look what it contains anyway, especcially if [s]he compiled MySQL manually.

Additionally mysql_install_db accepts option --no-defaults, so no editing of my.cnf is needed if you want it to be run successfully.

So this report looks like "Not a Bug" for me. If you disagree please describe what you want us to fix: comment skip-federated during compilation if MySQL configured without Federated storage engine or fix mysql_install_db, so it would not fail in case of such options?
[20 Feb 2009 13:03] Kamil Zbikowski
Thank you for your reply.

It was quite obvious for me that following instructions in the manual would give me a working system as a result. I've studied refman and everything that I found about 'no-defaults' option was that: "Don't read any option files.". So I didn't use it because I want to have control of configuration of the server. I've installed it form source in order to achieve that.

So, I know that it's not a serious problem but you have to agree that following installation steps  described in man would give this error. Maybe it's reasonable to add a comment about config and possible problem around the step about mysql_installation_db, isn't it? 

It won't be a bad idea to prepare a config file suitable for a options from compilation anyway. But few lines in the manual about what I've written above would be probably enough :)
[21 Feb 2009 8:55] Sveta Smirnova
Thank you for the feedback.

Verified as documentation bug: "please add into description of mysql_install_db information about it accepts option no-defaults"
[5 Mar 2009 18:24] Paul Dubois
Thank you for your bug report. This issue has been addressed in the documentation. The updated documentation will appear on our website shortly, and will be included in the next release of the relevant products.

Modified mysql_install_db section to point out that, in addition to its own unique options, it also supports option files and options for processing them.