Bug #42922 insertion of picture on blob or longblob
Submitted: 17 Feb 2009 9:46 Modified: 30 Nov 2016 9:47
Reporter: glend ruin Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / J Severity:S2 (Serious)
Version:5.1.6 OS:Microsoft Windows (vista home basic)
Assigned to: Alexander Soklakov CPU Architecture:Any
Tags: BLOB, incorrect picture format, insertion

[17 Feb 2009 9:46] glend ruin
Description:
while inserting a short picture into the field which type is longblob or blob ,the file size was not correct corresponding to the source file , and the actual size of content in field will be increased four bytes. so when fetch out the content via Connector J, the format of content will be influnced, the operation system can not recogenized it ! 

That's terriable !

when i used the previouse Connector/J , the apperance didn't occur, but no ConnectionPool,So how i resolve the problem?hah?

while inserting other format pictur such as .jpg .bmp ,some strange appearence occured and appeared mess code !

How to repeat:
by email

Suggested fix:
tell me the problem and the cause reason!
[17 Feb 2009 9:56] Tonci Grgin
Hi and thanks for your report.

Unfortunately, it does not give me anything to work on, no test case, no server/environment details and as such constitutes a free support request. If you wish we solve such problems for you on the basis of report like this, you should purchase a support contract.
On the other hand, if you want us to deal with problem here, you need to write much better problem report and attach small but complete test case.

So, what will it be?

PS: There is a regression test for just this in c/J sources under /src/testsuite.regression/BlobRegressionTest.java, you might find your answers there.
[18 Mar 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[30 Nov 2016 9:47] Alexander Soklakov
Posted by developer:
 
The reported behaviour isn't reproducible with current c/J code, connector saves and retrieves a correct number of bytes.