Bug #42912 Missing auto_increment flag
Submitted: 17 Feb 2009 7:31 Modified: 17 Feb 2009 8:12
Reporter: Aleksander Kujbida Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.1.7-1 OS:Linux (Ubuntu 8.04 on Toshiba Satellite U300)
Assigned to: CPU Architecture:Any
Tags: auto_increment, flags

[17 Feb 2009 7:31] Aleksander Kujbida
Description:
The column editor tab, there is no flag or other means to make a column auto_increment.

There is no workaround.

How to repeat:
Create a table either in the schema tab by clicking on Add table, or in a diagram by dragging a table to the diagram. Double click the table, which brings up the table edit tab. In the table editor tab, click on the Column tab. The flags listed in the Column Details area are Primary key, Unsigned, and Zerofill.

Check for widget broken: Click on any one flag then use up and down arrows to see if any more flags are there but the widget perhaps not showing a scrollbar, however up down arrows do not reveal any more flags: the flags widget seems to be working fine, just not showing auto_increment.
[17 Feb 2009 7:33] Aleksander Kujbida
Synopsis was wrong
[17 Feb 2009 7:59] Valeriy Kravchuk
What about AI flag for column in Columns tab? had you tried to check it?
[17 Feb 2009 8:06] Aleksander Kujbida
Hello Valeriy,
   You are correct: Checkbox in the AI column of the column editor works, and export proves that it does. I've been staring too hard at the screen looking for it, sorry for mistake, this bug does not exist.