Bug #42892 Main tests do not clean up after themselves
Submitted: 16 Feb 2009 16:36 Modified: 10 Mar 2009 12:44
Reporter: Alexander Nozdrin Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:6.0-TRUNK OS:Any
Assigned to: Assigned Account
Triage: Triaged: D3 (Medium)

[16 Feb 2009 16:36] Alexander Nozdrin
Description:
After pushing MTR2 there are warnings that the following tests do not
return environment to its original state:
  - main.flush_read_lock_kill

Complains are as follows:
  - main.flush_read_lock_kill
-----------------------------------------------------------------
@@ -37,7 +37,7 @@
 DEADLOCK_SEARCH_DEPTH_SHORT	4
 DEADLOCK_TIMEOUT_LONG	50000000
 DEADLOCK_TIMEOUT_SHORT	10000
-DEBUG	d,make_global_read_lock_block_commit_loop
+DEBUG	
 DEBUG_SYNC	ON - current signal: ''
 DEFAULT_WEEK_FORMAT	0
 DELAYED_INSERT_LIMIT	100
-----------------------------------------------------------------

How to repeat:
Run the test suite.
[10 Mar 2009 12:44] Alexander Nozdrin
It's a duplicate of Bug#38054.