Bug #42870 I_S.VIEWS VIEW_DEFINITION stores in lower
Submitted: 15 Feb 2009 22:37 Modified: 16 Feb 2009 5:49
Reporter: Jared S (Silver Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S3 (Non-critical)
Version:5.1.31 OS:Microsoft Windows (Vista)
Assigned to: CPU Architecture:Any
Tags: cr, DEFINITION, I_S, linefeed, LOWER, Views

[15 Feb 2009 22:37] Jared S
Description:
2 points.

 ● I_S.VIEWS.VIEW_DEFINITION won't hold CRs
 ● I_S.VIEWS.VIEW_DEFINITION won't hold UPPERCASE

The field is actually a blob and should store the "\r\n" sequence.  I am not sure why the server is forcing lower case.

How to repeat:
1. Create view..

2. SELECT  1
   FROM  mytable
   WHERE 1 = 1;

3. Alter view.

RESULT = "select 1 from mytable where 1 = 1;"
[16 Feb 2009 5:49] Valeriy Kravchuk
This is a variation of bug #14369 for INFORMATION_SCHEMA, which in turn was considered a duplicate of http://bugs.mysql.com/bug.php?id=5159. 

We have a WorkLog entry (still non-public, sorry) about both aspects of the problem. I hope it will be implemented eventually.