Bug #42860 MySQL Service won't start on Windows Vista platform
Submitted: 14 Feb 2009 19:02 Modified: 14 Jul 2010 5:35
Reporter: ron pat Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Windows Severity:S1 (Critical)
Version:mysql-5.1.31-win32 OS:Microsoft Windows (Windows Vista (TM) Enterprise x86)
Assigned to: CPU Architecture:Any
Tags: problem, service, start, vista

[14 Feb 2009 19:02] ron pat
Description:
MySQL service fails to start. When trying to manually start it,I get windows error code 1067:The process terminated unexpectedly. Manually executing MySQL.exe prints error: 2003 <HY000>: Can't connect to MySQL server on 'localhost' <10061>. Which I know is caused by MySQL service not running. I then installed XAMPP with MySQL 5.1.30 and it failed too. I have "FileZilla FTP Server 0.9.29" and "Apache 2.2.11" running smooth on the same box. I tried stopping both and allowing only MySQL to run but it still failed. I searched for solution online but have not had any luck, which is why I am reporting it to the creators, so that may be you can help me?

Thank you,
Ron

-MySQL 5.1.31 x86 AND 5.1.30 x86 (Service fails to start)
-Windows Vista Enterprise Edition x86 6001.vistasp1_gdr.080917-1612
-OTHER: Apache 2.2.11, FileZilla FTP Server 0.9.29

-
System   
--------------------------------------------------------------------------------
 
  Manufacturer Dell Inc.  
  Model OptiPlex 745  
  Total amount of system memory 2.00 GB RAM 
  System type 32-bit operating system 
  Number of processor cores 2 
  64-bit capable Yes 
 
Storage   
--------------------------------------------------------------------------------
 
  Total size of hard disk(s) 373 GB 
  Disk partition (C:) 24 GB Free (74 GB Total) 
  Disk partition (D:) 13 GB Free (298 GB Total) 
  Media drive (E:) CD/DVD 
 
Graphics   
--------------------------------------------------------------------------------
 
  Total available graphics memory Not detected 
        Dedicated graphics memory 0 MB 
        Dedicated system memory 0 MB 
        Shared system memory 0 MB 
  Display adapter driver version 6.14.10.4943 
  Primary monitor resolution 1280x1024 
  Secondary monitor resolution 1366x768 
  DirectX version DirectX 8 or earlier 
 
Network   
--------------------------------------------------------------------------------
 
  Network Adapter Broadcom NetXtreme 57xx Gigabit Controller 
  Network Adapter Microsoft Tun Miniport Adapter 
 

How to repeat:
install mysql version on vista stystem and you can see what i am talking about.
[14 Feb 2009 21:45] Miguel Solorzano
Thank you for the bug report. Looks like the server crashed, look in the data directory for a file host_name.err and see if there are error messages when the server stopped to work and print they here. Thanks in advance.
[15 Mar 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[23 Apr 2009 15:00] Patkos Csaba
I think I have the same problem, Windows Vista x86 (32bits), MySQL 5.1.32, fresh install of MySQL 5.1 after MySQL 5.0 was uninstalled (computer restarted).

Installation goes well, but when starting the service, Vista gives an "unable to start service" message and quits mysqld.exe. If i try to reconfigure it with the MySQL utility, it still can't start the service.

Below is the relevant part from the <my_hostname>.err file:

(See attached file neptune.err)

As this bug has no solution or indication please advise about it's state or if it is something configuration related please help work around this problem.

Thanks
[23 Apr 2009 15:00] Patkos Csaba
neptune.err

Attachment: Neptune.err (application/octet-stream, text), 100.69 KiB.

[13 Jul 2010 17:04] Dayhawk Kim
This problem persists in Windows 2008 Web Server, 32-bit. There does not seem to be a solution to this problem.
[14 Jul 2010 5:35] Sveta Smirnova
Thank you for the feedback.

This is duplicate of verified bug #50122. See also bug #45844 and comments for links to other related reports.
[14 Jul 2010 21:00] Vladislav Vaintroub
Folks, did anyone try latest, 5.1.alot (where alot is meanwhile == 48). The binary you try is meanwhile 1.5 years old, and there are 15 update releases since.  Chances are this is fixed, since I all reports about this bug I see reference 5.1.31 version or near it.