Bug #42802 .Net : Freshly created stored proc not found
Submitted: 12 Feb 2009 19:02 Modified: 12 Mar 2009 20:14
Reporter: Guillaume M Email Updates:
Status: No Feedback Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:5.2.5 OS:Microsoft Windows (Windows Seven 64)
Assigned to: Assigned Account CPU Architecture:Any
Tags: CALL, not found, stored procedure

[12 Feb 2009 19:02] Guillaume M
Description:
Some times, mysql doesnt see my stored proc.

How to repeat:
I have a small wizzard to migrate a database:

One : choose source server/db
Two : Target server
Three : create a new db on target server

All thoses steps are done with C# code using your connector.
Then,

Four : launch mysqldump on table_n
Five : launch mysql -e table_n.sql

repeat four and five for n tables.

Six : launch mysql -e createMyStoredProc.sql
Seven : Call stored proc (C# code using MySqlCommand and Parameter) => fail

A DbException is thrown saying that the storedproc does not exists!
If I change the code to a ExecuteNonQuery("CALL sp_myProc (42)");
It works!
If I copy the Seven step code (with MySqlCommand...) to another project and I run it (without other steps) it works... I don't know why, may be a problem with the pool, a problem with a stored proc freshly created...
[12 Feb 2009 20:14] Tonci Grgin
Hi Guillaume and thanks for your report.

I hate to say this but you'll get same answer for second one.
>> This does not look like bug report at all <<

Please attach small but *complete* test case demonstrating this problem each time I run it. Also, please include all necessary info for successful recreation of environment (in this case MySQL server version, .NET FW version, dump of database in question ...).
[13 Mar 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".