Bug #42631 Authentication packet not exposed to read_handshake/read_auth
Submitted: 5 Feb 2009 18:42 Modified: 3 Jun 2009 15:23
Reporter: Kay Roepke Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Proxy: Core Severity:S2 (Serious)
Version:0.7.0 OS:Any
Assigned to: Assigned Account

[5 Feb 2009 18:42] Kay Roepke
Description:
The read_handshake and read_auth lua functions do not have access to the auth packet.

How to repeat:
function read_handshake( auth )
   print("<-- let's send him some information about us")
   print("    mysqld-version: " .. auth.mysqld_version)
end

Suggested fix:
Expose all fields of the packet.
[3 Jun 2009 15:23] Kay Roepke
same as bug#45074, closing this one
[31 Aug 2009 21:56] Renan RdS
I still get the error using this function:

function read_auth( auth )
  print("username: " .. auth.username)
end

ERROR:
2009-08-31 18:54:51: (critical) (read_auth) [string "/mysql-proxy/teste.lua"]:16: attempt to index local 'auth' (a nil value)

That´s the only function I have implemented so far.