Bug #42398 Error number 5, during server startup (Win Vista)
Submitted: 27 Jan 2009 23:38 Modified: 3 Feb 2009 19:03
Reporter: Helio Rodrigues Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Windows Severity:S1 (Critical)
Version:5.1.30 OS:Windows (Vista)
Assigned to: CPU Architecture:Any
Tags: ib_logfile0, innodb, startup

[27 Jan 2009 23:38] Helio Rodrigues
During the normal startup the program exhibits the following messages:
C:\>mysqld --console
090127 18:32:14  InnoDB: Operating system error number 5 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory. It may also be you have created a subdirectory
InnoDB: of the same name as a data file.
InnoDB: File name .\ib_logfile0
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.

How to repeat:
Install the version 5.1.30, using the zip file mysql-5.1.30-win32.zip available at http://dev.mysql.com/downloads/mysql/5.1.html#win32.
After installing and configuring just run as "<PATH>\mysqld" --console
[27 Jan 2009 23:48] Helio Rodrigues
I have tried to uninstall and install in a different path.
   - First at Win suggested path: C:\Program Files\MySQL\MySQL Server 5.1\
   - Second at: C:\MySQLServer51\

And I also gave the permission to all users fro full control in all C drive.
[28 Jan 2009 0:43] MySQL Verification Team
Thank you for the bug report. When intalling have you selected the option to install as service?. Thanks in advance.
[28 Jan 2009 2:13] Helio Rodrigues
In the first installation: Yes.
In the second installation: No.

I believe I solved the first problem.
During the second installation even if I choose the path "C:\MySQLServer51\" the my.ini file put the variable datadir with the default path "C:\Program Files\MySQL\MySQL Server 5.1\"

When I changed manually to "C:\MySQLServer51\" it solved the first problem and generate a new one, described below.

C:\>mysqld --console
mysqld: Table 'mysql.plugin' doesn't exist
090127 19:27:48 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgr
ade to create it.
InnoDB: Log scan progressed past the checkpoint lsn 0 39548
090127 19:27:48  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 0 46409
090127 19:27:48  InnoDB: Starting an apply batch of log records to the database.
InnoDB: Progress in percents: 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69
 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 9
6 97 98 99
InnoDB: Apply batch completed
090127 19:27:49  InnoDB: Started; log sequence number 0 46409
090127 19:27:49 [ERROR] Fatal error: Can't open and lock privilege tables: Table
 'mysql.host' doesn't exist
[28 Jan 2009 18:39] Helio Rodrigues
I turned off the User Account Control from Vista and the MySQL started successfully.

Thanks for the help.
[3 Feb 2009 19:03] Sveta Smirnova
Thank you for the feedback.

Report closed as "Not a Bug" because last comment.
[10 May 2010 10:58] patcharee sirichavalit
้this problem occur on Linux