Bug #42328 omit schema qualifiers does not omit schema for foreign keys
Submitted: 25 Jan 2009 16:57 Modified: 8 Jun 2009 12:10
Reporter: Bastian Grupe Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.0.29 OSS OS:Microsoft Windows
Assigned to: Alexander Musienko CPU Architecture:Any
Tags: CHECKED
Triage: Triaged: D2 (Serious) / R3 (Medium) / E3 (Medium)

[25 Jan 2009 16:57] Bastian Grupe
Description:
Hi,

when exporting to SQL CREATE script and checking the "omit schema qualifiers" checkbox schemas are omitted except for foreign keys. 

This might be desired behaviour for schemas which are not the current one but render the "omit schema" checkbox useless if you only work within one schema.

How to repeat:
1) File -> Export -> Forward Engineer SQL CREATE script
2) [x] omit schema qualifiers from output

Suggested fix:
Omit schema qualifiers if referenced schema is the same as current one
[26 Jan 2009 12:19] Valeriy Kravchuk
Thank you for a problem report. Verified just as described.
[12 Mar 2009 14:14] Susanne Ebrecht
This is related to bug #43485
[20 Mar 2009 15:16] Jon
This bug is still present in 5.0.30.
[20 Apr 2009 10:05] Valeriy Kravchuk
Bug #44362 was marked as a duplicate of this one.
[30 Apr 2009 16:51] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=44580 marked as duplicate of this one.
[1 Jun 2009 1:20] Greg Wright
Having the same problem in the Mac beta version of 5.1.12 Revision 4000.
[2 Jun 2009 13:13] Mike Lischke
Fixed/implemented in 5.1 (rev 4073) and 5.2 (rev. 3710).
[3 Jun 2009 22:18] Johannes Taxacher
schema qualifier correctly removed. fix will be included in 5.1.13
[8 Jun 2009 12:10] Tony Bedford
An entry was added to the 5.1.13 changelog:

Omit Schema Qualifiers did not omit schema for foreign keys.

When using File, Export, Forward Engineer SQL CREATE Script and selecting the Omit Schema Qualifiers checkbox, the schema for foreign keys were not omitted.