Bug #42325 Text fields return 'x' when empty
Submitted: 25 Jan 2009 1:29 Modified: 24 Feb 2010 14:40
Reporter: Matthew Adams Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.0.45 OS:Microsoft Windows (XP SP2)
Assigned to: CPU Architecture:Any

[25 Jan 2009 1:29] Matthew Adams
Description:
If at text field is empty in classic asp and it is requested using the following:
<%=(ease.Fields.Item("NATIONALITY").Value)%>

If the text field is empty it returns 'x'

Driver:
Driver={MySQL ODBC 3.51 Driver};Server=****;Port=3306;Database=****;User=****;Password=****;Option=3;

How to repeat:
Repeats with any empty field which is text

Suggested fix:
Work round is to change type to CHAR or VARCHAR
[25 Jan 2009 9:45] Valeriy Kravchuk
Thank you for a problem report. What exact version of MyODBC, 3.5.1.xx, do you use? Have you tried the latest one, 3.51.27?
[26 Feb 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[24 Feb 2010 14:40] Tonci Grgin
Duplicate of Bug#23264 which is fixed.