Bug #42290 Execution of 'drop trigger if exists' fails if not exists
Submitted: 23 Jan 2009 4:18 Modified: 16 Feb 2009 16:30
Reporter: Lee Clemens Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.2.15 OS:Microsoft Windows (XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any

[23 Jan 2009 4:18] Lee Clemens
Description:
Execution of script with "DROP TRIGGER IF EXISTS `<trigger_name>`;

fails and stops in debugging mode. Cannot continue using "Continue" or "Step".

How to repeat:
Create new schema
Execute script with "DROP TRIGGER IF EXISTS `<trigger_name>`;

Suggested fix:
This statement should not fail to execute, and should not stop the script from executing (especially not stop at a debug point without making it a debug point)
[23 Jan 2009 8:29] Valeriy Kravchuk
Thank you for a problem report. What exact version of MySQL server are you working with?
[23 Jan 2009 15:36] Lee Clemens
Server is mysql-5.0.45-linux-i686-icc-glibc23
Kernel is 2.6.18-92.1.18.el5xen
[23 Jan 2009 15:58] MySQL Verification Team
Thank you for the bug report.
[16 Feb 2009 12:19] Mike Lischke
Please try the latest version of QB. I cannot reproduce this problem with the current code base. Note: in the query area you get a message that the trigger does not exist, but it's a note, not an error. In the script editor it just executes as expected.
[16 Feb 2009 16:30] Lee Clemens
This bug was created when executing from a script, so I do not see the warning.

However, the issue does appear to be fixed in the latest release, 1.2.16, of Query Browser.

Thanks!