Bug #4215 Intel 4.1.2 mysql_install_db fails
Submitted: 18 Jun 2004 23:30 Modified: 20 Aug 2004 15:25
Reporter: Darryl Rodden Email Updates:
Status: Duplicate Impact on me:
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:4.1.2 OS:REL 3
Assigned to: Assigned Account CPU Architecture:Any

[18 Jun 2004 23:30] Darryl Rodden

I have 4.1.2 installed and running on a REL 3 server.  I was
curious about the Intel compiled version, so I installed the 
Intel compiled 4.1.2 to see if I would get a performance 
increase.  I am having trouble with it.  I put this question 
out on the General Discussion list, but did not receive any 
helpful information.  I don't know if this is a bug or not.  

The Intel scripts/mysql_install_db is giving me the following 

Neither host 'devlhvm03.sdl1.secureserver.net' and 'localhost' 
could not be looked up with ./bin/resolveip 
Please configure the 'hostname' command to return a correct
If you want to solve this at a later stage, restart this script
with the --force option

Both were installed from the binary distribution and I followed
the install instructions in both cases.  The only exception is 
that I did not have to create the mysql user and group when
I installed the Intel compiled version.  These are the files I
downloaded and installed:


Here is what hostname returns:

Here is the /etc/hosts:	localhost.localdomain localhost	devlhvm03.sdl1.secureserver.net devlhvm03

If I run the resolveip directly, here is what I get:

#/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686/bin/resolveip `hostname`
IP address of devlhvm03.sdl1.secureserver.net is
#/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686/bin/resolveip devlhvm03.sdl1.secureserver.net
IP address of devlhvm03.sdl1.secureserver.net is

#/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686-icc/bin/resolveip `hostname`
/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686-icc/bin/resolveip: Unable to find hostid for
'devlhvm03.sdl1.secureserver.net': no recovery
#/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686-icc/bin/resolveip devlhvm03.sdl1.secureserver.net
/usr/local/mysql-standard-4.1.2-alpha-pc-linux-i686-icc/bin/resolveip: Unable to find hostid for
'devlhvm03.sdl1.secureserver.net': no recovery

Any ideas?


How to repeat:
See above.
[23 Jun 2004 23:04] Matthew Lord
This is not a bug, you should try using the --force option.   I should tell you that I have personally had 
problems with the icc build.

Best Regards
[24 Jun 2004 0:23] Darryl Rodden
Hello Mathew,

That gets me past that problem, but I ran into another one when I start up the database (bin/mysqld_safe --user=mysql &), see below.  I was running as root when I started it.  This works OK with the normal distribution, but apparently not with the icc build.  I changed to the mysql user (su mysql) and it started correctly.  What kinds of problems have you run into with the icc build?


040623 14:52:36  mysqld started
Fatal error: Can't change to run as user 'mysql' ;  Please check that the user exists!
040623 14:52:36  Aborting
040623 14:52:36  /usr/local/mysql/bin/mysqld: Shutdown Complete
040623 14:52:36  mysqld ended
[24 Jun 2004 0:40] Matthew Lord
I've posted a bug about this as well here:

I also noticed that net_buffer_length is not growing and I posted a bug about that here:
[20 Aug 2004 1:06] Brian Aker
Lenz, after you build on a 64bit with dynamic libs, see if these bugs still occur (you can kick this 
back to support to verify if you want to).
[20 Aug 2004 15:25] Lenz Grimmer
This bug was marked as a duplicate of BUG#4408