Bug #42142 BLOB data does not transfer
Submitted: 15 Jan 2009 22:17
Reporter: Scott Noyes Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:1.1.15 OS:Microsoft Windows
Assigned to:
Triage: Triaged: D3 (Medium) / R3 (Medium) / E3 (Medium)

[15 Jan 2009 22:17] Scott Noyes
Description:
The SQL generated by the migration tool kit does not include the values for BLOB data. For the test shown, the general query log from the target server contains the following statement:

INSERT INTO `test`.`t1`(`b`) VALUES ('')

How to repeat:
I ran the following on the source server:

CREATE TABLE t1 (b BLOB);
INSERT INTO t1 VALUES ('test');

I ran the Migration Toolkit to copy this table from one MySQL server to another, leaving all defaults. I also tried it with the 'BLOB streaming' option, and no UPDATE statement was generated.

Suggested fix:
The generated SQL ought to contain the blob values.
[19 Oct 2009 13:47] Susanne Ebrecht
Many thanks for writing a bug report. We are on the way to implement full functionality of MySQL Migration Toolkit into MySQL Workbench and won't fix this anymore.

But we will consider this during implementation into Workbench.