Bug #42029 Cannot connect to mysql via localhost
Submitted: 11 Jan 2009 14:21 Modified: 11 Jan 2009 17:05
Reporter: Robert Mundy Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.1 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[11 Jan 2009 14:21] Robert Mundy
Description:
I cannot connect to mysql via localhost.  I have reinstalled mysql several times but I cannot get it to work.  I have deleted the data folder in mysql (C:\User\USER\AppData\roaming in Vista.  I still get the same cannot connect error.

What file holds the fact that I cannot connect to localhost so I can delete that file?  The command I accidentally ran was:

 UPDATE mysql.user SET Host = '*';

I was supposed to enter:

 UPDATE mysql.user SET Host = '%';

Using '*' instead of '%' has caused this problem

How to repeat:
Run the command:

UPDATE mysql.user SET Host = '*';
[11 Jan 2009 14:27] Sveta Smirnova
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.

Please read at http://dev.mysql.com/doc/refman/5.1/en/resetting-permissions.html how to restart MySQL server in mode which will allow you to fix privilege tables.
[11 Jan 2009 17:05] Robert Mundy
This is a bug because no one should be able to run any command that totally shuts down mysql on a machine permanently.  There should be a way to recover the server.  If reinstalling mysql is not how it is done, then I need to know how to do it.  There is no other forum on this topic for Windows.