Bug #4201 Script in bitkeeper won't run.
Submitted: 18 Jun 2004 13:25 Modified: 19 Jun 2004 10:16
Reporter: Arnold Daniels Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.0 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any

[18 Jun 2004 13:25] Arnold Daniels
Description:
Trying to run a mysql script in bitkeeper always gives 'Error: You must run this script from the top-level mysql directory'.

NOTE: There is an incorrectness in the documentation in chapter 2.3.6.2:
    shell> ./scripts/make_win_src_distribution
should state
    shell> ./scripts/make_win_src_distribution.sh

How to repeat:
After starting the command shell with msys.bat (profided by bitkeeper).

Arnold@ARNOLD ~\mysql-5.0
$ ./scripts/make_win_src_distribution.sh
Error: You must run this script from the top-level mysql directory
[18 Jun 2004 14:38] MySQL Verification Team
The scripts/make_win_src_distribution only works after you have
built the Unix stuff. So you can do before as example:

BUILD/compile-pentium-max

and when it finished run scripts/make_win_src_distribution
[18 Jun 2004 16:35] Arnold Daniels
Screendumb bitkeeper (1 of 2)

Attachment: MINGW32-a.gif (image/gif, text), 26.09 KiB.

[18 Jun 2004 16:36] Arnold Daniels
Screendumb bitkeeper (2 of 2)

Attachment: MINGW32-b.gif (image/gif, text), 30.21 KiB.

[18 Jun 2004 16:37] Arnold Daniels
I do think this is a bug. I followed the manual by the letter. Please take a look at the screendumps.
[18 Jun 2004 17:20] MySQL Verification Team
Please read: http://dev.mysql.com/doc/mysql/en/Installing_source_tree.html

Item 4.

You will need GNU make, autoconf 2.53 (or newer), automake 1.5, libtool 1.5, and m4 to run the next set of commands. Even though many operating systems already come with their own implementation of make, ....
[18 Jun 2004 17:39] Arnold Daniels
I am confused. I'm am trying to compile MySQL 5.0 on Windows XP. Reading the chapter '2.3.6.2 Creating a Windows Source Package from the Latest Development Source', made me believe I only had to follow chapter 2.3.3 untill step 3 'making the clone'. Step 4 up was is about building mysql and this goes different for windows.

------------------------------ 
Clone the BitKeeper source tree for MySQL (version 4.1 or above, as desired). For more information on how to clone the source tree, see the instructions at section 2.3.3 Installing from the Development Source Tree. 
------------------------------

If I'm mistaking and just don't get it, perhaps I'll just stop trying.
[19 Jun 2004 10:16] Sergei Golubchik
you're almost right. But still the manual says:

  2. Configure and build the distribution so that you have a server
     binary to work with.  One way to do this is to run the following
     command in the top-level directory of your source tree:

          shell> ./BUILD/compile-pentium-max

  3. After making sure that the build process completed successfully,
     run the following utility script...

But the build process did not complete successfully, that's why make_win_src_distribution failed. And build process did not complete because you do not have auto* tools installed.