Bug #41855 Windows 98 installs still receive "[ERROR] Can't find messagefile"
Submitted: 5 Jan 2009 6:43 Modified: 23 Jan 2009 7:33
Reporter: M D Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Windows Severity:S2 (Serious)
Version:5.1.30 OS:Microsoft Windows (Windows 98 SE)
Assigned to: CPU Architecture:Any
Tags: Contribution, language errsys messagefile

[5 Jan 2009 6:43] M D
Description:
This bug seems to be a duplicate of the closed bug:
http://bugs.mysql.com/bug.php?id=32257

Though this bug did not exist in 5.0.20a-max, the bug is current repeatable on Win 98 SE using General Release 5.1.30 

090105  1:07:36 [ERROR] Can't find messagefile 'C:\path\to\errmsg.sys'
090105  1:07:36 [Warning] Can't create test file C:\mysql_db\data\Data\compname.lo
wer-test
090105  1:07:36 [Warning] Can't create test file C:\mysql_db\data\Data\compname.lo
wer-test

All of the following result in the same error:
mysqld --language="C:\path\to\errmsg.sys" --no-defaults

mysqld --language="C:\path\to\errmsg.sys" --defaults-file="C:\path\to\my.ini" 

mysqld --defaults-file="C:\path\to\my.ini" 

mysqld-debug --language="C:\path\to\errmsg.sys" --defaults-file="C:\path\to\my.ini"

*******************************
*******************************

Applying the following patch seems to suppress this particular error, though I cannot yet confirm whether or not it allows the server to actually run as expected.
http://forums.mysql.com/read.php?11,59081,59691#msg-59691

How to repeat:
Install MySQL using available binary.
Configure MySQL using packaged configuration app and create minimal my.cnf file
Attempt to run mysqld

Suggested fix:
If the patch works, then make it more easily available with whatever disclaimers are necessary for Win98 users.
[5 Jan 2009 9:41] Valeriy Kravchuk
Thank you for a problem report. I had re-opened Bug #32257. Do you agree to consider this your report as a duplicate?
[23 Jan 2009 5:52] M D
Yes.

Agree that this is a duplicate of Bug #32257
[23 Jan 2009 7:33] Valeriy Kravchuk
Duplicate of Bug #32257.