Bug #41839 Crash in mysqld.exe!ha_partition::handle_ordered_next()[ha_partition.cc:4520]
Submitted: 3 Jan 2009 13:03 Modified: 3 Jan 2009 13:06
Reporter: Wolfgnag Purrer Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Partitions Severity:S1 (Critical)
Version:5.1.29 OS:Microsoft Windows (2008)
Assigned to:

[3 Jan 2009 13:03] Wolfgnag Purrer
Description:
090103  6:01:05 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=314572800
read_buffer_size=65536
max_used_connections=107
max_threads=500
threads_connected=7
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1268024 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x16035f40
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
0043C97E    mysqld.exe!ha_partition::handle_ordered_next()[ha_partition.cc:4520]
004403CF    mysqld.exe!ha_partition::read_range_next()[ha_partition.cc:4092]
00445376    mysqld.exe!handler::read_multi_range_next()[handler.cc:4063]
004D0F54    mysqld.exe!QUICK_RANGE_SELECT::get_next()[opt_range.cc:8401]
004E2420    mysqld.exe!rr_quick()[records.cc:313]
0057A9D4    mysqld.exe!sub_select()[sql_select.cc:11061]
0058F0E7    mysqld.exe!do_select()[sql_select.cc:10811]
00590239    mysqld.exe!JOIN::exec()[sql_select.cc:2183]
00590893    mysqld.exe!mysql_select()[sql_select.cc:2363]
00590CDC    mysqld.exe!handle_select()[sql_select.cc:269]
0055060F    mysqld.exe!execute_sqlcom_select()[sql_parse.cc:4828]
00551B70    mysqld.exe!mysql_execute_command()[sql_parse.cc:2136]
00558850    mysqld.exe!mysql_parse()[sql_parse.cc:5731]
005593F8    mysqld.exe!dispatch_command()[sql_parse.cc:1154]
0055A36A    mysqld.exe!do_command()[sql_parse.cc:809]
005E020B    mysqld.exe!handle_one_connection()[sql_connect.cc:1115]
0064537B    mysqld.exe!pthread_start()[my_winthread.c:85]
00731B6A    mysqld.exe!_threadstart()[thread.c:196]
76424911    kernel32.dll!BaseThreadInitThunk()
779CE4B6    ntdll.dll!RtlInitializeExceptionChain()
779CE489    ntdll.dll!RtlInitializeExceptionChain()
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 17582CA0=select name, count(zeitpunkt) as anzahl from meldungen,anlagen  where meldungen.typ=1  and ( meldungen.typ !='97') and meldungen.zeitpunkt>SUBDATE(now(),INTERVAL 24 HOUR) and (meldungen.anlage>18)  and (meldungen.anlage<24)  and anlagen.nr=meldungen.anlage and(now()-zeitpunkt) < 20 group by anlage
thd->thread_id=22183
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

=> i did a restart

090103 13:55:17 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.29-rc-community-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
090103 13:58:12 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=314572800
read_buffer_size=65536
max_used_connections=6
max_threads=500
threads_connected=6
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1268024 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x16be2c98
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
0043C97E    mysqld.exe!ha_partition::handle_ordered_next()[ha_partition.cc:4520]
004403CF    mysqld.exe!ha_partition::read_range_next()[ha_partition.cc:4092]
00445376    mysqld.exe!handler::read_multi_range_next()[handler.cc:4063]
004D0F54    mysqld.exe!QUICK_RANGE_SELECT::get_next()[opt_range.cc:8401]
004E2420    mysqld.exe!rr_quick()[records.cc:313]
0057A9D4    mysqld.exe!sub_select()[sql_select.cc:11061]
0058F0E7    mysqld.exe!do_select()[sql_select.cc:10811]
00590239    mysqld.exe!JOIN::exec()[sql_select.cc:2183]
00590893    mysqld.exe!mysql_select()[sql_select.cc:2363]
00590CDC    mysqld.exe!handle_select()[sql_select.cc:269]
0055060F    mysqld.exe!execute_sqlcom_select()[sql_parse.cc:4828]
00551B70    mysqld.exe!mysql_execute_command()[sql_parse.cc:2136]
00558850    mysqld.exe!mysql_parse()[sql_parse.cc:5731]
005593F8    mysqld.exe!dispatch_command()[sql_parse.cc:1154]
0055A36A    mysqld.exe!do_command()[sql_parse.cc:809]
005E020B    mysqld.exe!handle_one_connection()[sql_connect.cc:1115]
0064537B    mysqld.exe!pthread_start()[my_winthread.c:85]
00731B6A    mysqld.exe!_threadstart()[thread.c:196]
76424911    kernel32.dll!BaseThreadInitThunk()
779CE4B6    ntdll.dll!RtlInitializeExceptionChain()
779CE489    ntdll.dll!RtlInitializeExceptionChain()
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 16BEDD70=SELECT meldungen.zeitpunkt,meldungen.anlage as anlagennr,meldungen.typ as typnr,meldungen.loghelper, meldungen.subanlage as subanlagenname, meldungen.text,  TIME_FORMAT(SEC_TO_TIME(UNIX_TIMESTAMP(endzeitpunkt)- UNIX_TIMESTAMP(zeitpunkt)),'%H:%i:%s') as timediv FROM meldungen WHERE 1=1  and ( meldungen.typ='5') and meldungen.zeitpunkt>SUBDATE(now(),INTERVAL 24 HOUR) and (meldungen.anlage>18)  and (meldungen.anlage<24)  order by meldungen.anlage,meldungen.zeitpunkt ,meldungen.loghelper  limit 200
thd->thread_id=8
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
I don't know just simply happend

the application is running ok for about 2 month.

I restarted the server and after I went on a php - page (which sends the query the same happend again)
[3 Jan 2009 13:06] Wolfgnag Purrer
http://bugs.mysql.com/bug.php?id=40494

Sorry Duplicate...