Bug #41833 Error in installing mysql-connector-odbc-5.1.5-0.i386.rpm
Submitted: 3 Jan 2009 5:03 Modified: 5 Feb 2009 13:46
Reporter: naveen chakravarthi Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.1.5-0 OS:Any
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D2 (Serious)

[3 Jan 2009 5:03] naveen chakravarthi
Description:
sir,
i tried to install the odbc connector in linux....it is showing some error.. sir as am new to this software can you please help me out..
rpm -iv --replacepkgs
mysql-connector-odbc-5.1.5-0.i386.rpm
warning: mysql-connector-odbc-5.1.5-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing packages for installation...
mysql-connector-odbc-5.1.5-0
myodbc-installer: symbol lookup error: myodbc-installer: undefined symbol:
SQLInstallDriverExW
error: %post(mysql-connector-odbc-5.1.5-0.i386) scriptlet failed, exit status 127

How to repeat:
jus installed the rpm file..
[3 Jan 2009 18:04] Valeriy Kravchuk
Verified just as described on SuSE Linux 9.3:

suse:/home/openxs # rpm -iv --replacepkgs mysql-connector-odbc-5.1.5-0.i386.rpm
warning: mysql-connector-odbc-5.1.5-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing packages for installation...
mysql-connector-odbc-5.1.5-0
myodbc-installer: symbol lookup error: myodbc-installer: undefined symbol: SQLInstallDriverExW
error: %post(mysql-connector-odbc-5.1.5-0) scriptlet failed, exit status 127
suse:/home/openxs # rpm -iv --replacepkgs mysql-connector-odbc-setup-5.1.5-0.i386.rpm
warning: mysql-connector-odbc-setup-5.1.5-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing packages for installation...
mysql-connector-odbc-setup-5.1.5-0
warning: user mysqldev does not exist - using root
warning: group mysqldev does not exist - using root
warning: user mysqldev does not exist - using root
warning: group mysqldev does not exist - using root
warning: user mysqldev does not exist - using root
warning: group mysqldev does not exist - using root
myodbc-installer: symbol lookup error: myodbc-installer: undefined symbol: SQLRemoveDriverW
myodbc-installer: symbol lookup error: myodbc-installer: undefined symbol: SQLInstallDriverExW
error: %post(mysql-connector-odbc-setup-5.1.5-0) scriptlet failed, exit status 127
[1 Feb 2009 12:46] Valeriy Kravchuk
I have unixODBC-2.2.10-3 on this box.
[3 Feb 2009 17:54] Jess Balint
Connector/ODBC 5.1 requires unixODBC 2.2.12 or later. From unixODBC changelog:

Add UNICODE wrapper functions in libodbcinst. The ini file is still ascii, so its not got full support at the moment, but any apps that need the W functions should build now
[5 Feb 2009 13:46] Tony Bedford
I've added a note to this effect in the Unix install section of the Connector/ODBC documentation.
[18 Feb 2009 17:30] Tonci Grgin
Bug#40405 was marked as duplicate of this report.