Bug #41655 sporadic pushbuild failure in events_bugs: missing lines in output
Submitted: 20 Dec 2008 11:06 Modified: 5 Jan 2009 12:54
Reporter: Sven Sandberg Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:5.1, 6.0 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Tags: events_bugs, pushbuild, sporadic, test failure
Triage: Triaged: D3 (Medium)

[20 Dec 2008 11:06] Sven Sandberg
Description:
Sporadic pushbuild failure started to happen on 2008-11-06:

main.events_bugs                         [ fail ]
        Test ended at 2008-12-19 22:38:04

CURRENT_TEST: main.events_bugs
--- /data0/pushbuild/pb/bzr_mysql-5.1-rpl/108/bzr_mysql-5.1-rpl-exp/mysql-test/r/events_bugs.result	2008-12-19 23:21:43.000000000 +0300
+++ /data0/pushbuild/pb/bzr_mysql-5.1-rpl/108/bzr_mysql-5.1-rpl-exp/mysql-test/r/events_bugs.reject	2008-12-20 00:38:04.000000000 +0300
@@ -131,7 +131,6 @@
 select * from events_smode_test order by ev_name, a;
 ev_name	a
 ee_16407_3	1980-02-19
-ee_16407_3	1980-02-29
 ee_16407_4	0000-00-00
 "OK, last check before we drop them"
 select event_schema, event_name, sql_mode from information_schema.events order by event_schema, event_name;

mysqltest: Result content mismatch

 - saving '/dev/shm/var-n_mix-130/log/main.events_bugs/' to '/dev/shm/var-n_mix-130/log/main.events_bugs/'

Retrying test, attempt(2/3)...

How to repeat:
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-5.1-rpl&order=108 sapsrv1/n_mix
xref: http://tinyurl.com/8jfxsq

See also BUG#41111, BUG#39863, BUG#37774, BUG#39569, BUG#39848 for other bugs in this test case.
[5 Jan 2009 12:54] Matthias Leich
This bug seems to be a duplicate of the failure
reported in 
Bug#41111 events_bugs fails sporadically on pushbuild
   (http://bugs.mysql.com/bug.php?id=41111)
Comment: [28 Nov 19:25] Matthias Leich
   ...
   --- r/events_bugs.result
   +++ r/events_bugs.reject
   @@ -130,8 +130,6 @@
    set global event_scheduler= off;
    select * from events_smode_test order by ev_name, a;
    ev_name        a
   -ee_16407_3     1980-02-19
   -ee_16407_3     1980-02-29
   ee_16407_4     0000-00-00
   "OK, last check before we drop them"
   ...
The only difference between both bad effects is the
amount of missing result set rows.
Therefore I declare this bug to be a duplicate of
Bug#41111. This all has to be fixed by the patch
for Bug#41111.