Bug #41618 fulltext_distinct fails sporadically on pushbuild with timeout
Submitted: 19 Dec 2008 6:43 Modified: 5 Jan 2009 12:07
Reporter: Sven Sandberg Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:6.0 OS:Any
Assigned to: CPU Architecture:Any
Tags: fulltext_distinct, pushbuild, sporadic, test failure, timeout
Triage: Triaged: D3 (Medium)

[19 Dec 2008 6:43] Sven Sandberg
Description:
main.fulltext_distinct                   [ fail ]  timeout after 900 seconds
        Test ended at 2008-12-08 18:35:36

Test case timeout after 900 seconds

== /dev/shm/var-embedded-111/log/fulltext_distinct.log == 
SELECT * FROM t1;
id	tag	value
1	foo123	bar111
2	foo123	bar222
3	bar345	baz333 ar
SELECT * FROM t2;
id_t2	id_t1	field_number
12346	3	1
2231626	64280	0
2231626	64281	0
SELECT DISTINCT t2.id_t2 FROM t2, t1
WHERE MATCH (t1.value) AGAINST ('baz333') AND t1.id = t2.id_t1;
id_t2
12346
SELECT DISTINCT t2.id_t2 FROM t2, t1
WHERE MATCH (t1.value) AGAINST ('baz333' IN BOOLEAN MODE)
AND t1.id = t2.id_t1;
id_t2
12346
DROP TABLE t1, t2;

 - saving '/dev/shm/var-embedded-111/log/main.fulltext_distinct/' to '/dev/shm/var-embedded-111/log/main.fulltext_distinct/'

Retrying test, attempt(2/3)...

How to repeat:
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-6.0-rpl&order=119 sapsrv2/embedded
xref: http://tinyurl.com/4w2yea
[5 Jan 2009 12:07] Alfranio Correia
This is a duplicate of BUG#41861 which will be possible to fix after BUG#40399 has been fixed.